aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-08-29 12:47:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-08-29 12:48:28 +0000
commitc75d84cc644bb19933ad2667b45556263b16a8d8 (patch)
treebf7a132e79c22588ddde590aeea625a25e41febd
parent0b99eb3df5030a2b3765793a6e4632cbc4293c29 (diff)
downloadaports-c75d84cc644bb19933ad2667b45556263b16a8d8.tar.bz2
aports-c75d84cc644bb19933ad2667b45556263b16a8d8.tar.xz
testing/virtualbox-additions-grsec: new aport
Virtual box addtions kernel modules for grsec http://virtualbox.org
-rw-r--r--testing/virtualbox-additions-grsec/APKBUILD66
-rw-r--r--testing/virtualbox-additions-grsec/virtualbox-modules-4.1.4-pax-const.patch48
2 files changed, 114 insertions, 0 deletions
diff --git a/testing/virtualbox-additions-grsec/APKBUILD b/testing/virtualbox-additions-grsec/APKBUILD
new file mode 100644
index 0000000000..d7d6d02f5a
--- /dev/null
+++ b/testing/virtualbox-additions-grsec/APKBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+
+_flavor=grsec
+_kver=3.4.9
+_kpkgrel=0
+
+# when chaning _ver we *must* bump _mypkgrel
+_ver=4.1.20
+_mypkgrel=0
+_name=virtualbox-addtions
+
+# verify the kernel version before entering chroot
+_kapkbuild=../../linux-${_flavor}/APKBUILD
+if [ -f $_kapkbuild ]; then
+ . $_kapkbuild
+ pkgname=$_name-$_flavor
+ [ "$_kver" != "$pkgver" ] && die "please update _kver to $pkgver"
+ [ "$_kpkgrel" != "$pkgrel" ] && die "please update _kpkgrel to $pkgrel"
+fi
+
+_kpkgver="$_kver-r$_kpkgrel"
+_abi_release=${_kver}-${_flavor}
+
+pkgname=${_name}-${_flavor}
+pkgver=$_kver
+pkgdesc="Virtual box addtions kernel modules for $_flavor "
+arch="x86"
+url='http://virtualbox.org'
+license="GPL custom"
+makedepends="linux-grsec-dev"
+source="http://dev.gentoo.org/~polynomial-c/virtualbox/vbox-kernel-module-src-$_ver.tar.xz
+ virtualbox-modules-4.1.4-pax-const.patch
+ "
+
+_builddir="$srcdir"/
+
+prepare() {
+ cd "$_builddir"
+ local i
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+
+ export KERN_DIR=/usr/src/linux-headers-${_abi_release}
+ export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
+ make
+}
+
+package() {
+ local module=
+ cd "$_builddir"
+ for module in *.ko; do
+ install -D -m644 $module \
+ "$pkgdir/lib/modules/${_abi_release}/misc/$module" \
+ || return 1
+ done
+}
+
+md5sums="df055d44c71a96250131536497fe32f2 vbox-kernel-module-src-4.1.20.tar.xz
+4bbbce6902722a7439f6fac4d17c6051 virtualbox-modules-4.1.4-pax-const.patch"
diff --git a/testing/virtualbox-additions-grsec/virtualbox-modules-4.1.4-pax-const.patch b/testing/virtualbox-additions-grsec/virtualbox-modules-4.1.4-pax-const.patch
new file mode 100644
index 0000000000..5e89ab43c8
--- /dev/null
+++ b/testing/virtualbox-additions-grsec/virtualbox-modules-4.1.4-pax-const.patch
@@ -0,0 +1,48 @@
+diff -urp vboxdrv.orig/SUPDrvIDC.h vboxdrv/SUPDrvIDC.h
+--- a/vboxdrv.orig/SUPDrvIDC.h 2011-09-06 15:53:27.852567531 +0200
++++ b/vboxdrv/SUPDrvIDC.h 2011-09-06 15:54:05.420565524 +0200
+@@ -160,7 +160,7 @@ typedef struct SUPDRVIDCREQGETSYM
+ {
+ /** The symbol address. */
+ PFNRT pfnSymbol;
+- } Out;
++ } __no_const Out;
+ } u;
+ } SUPDRVIDCREQGETSYM;
+ /** Pointer to a SUPDRV IDC get symbol request. */
+diff -urp vboxnetflt.orig/include/VBox/intnet.h vboxnetflt/include/VBox/intnet.h
+--- a/vboxnetflt.orig/include/VBox/intnet.h 2011-09-06 15:53:27.852567531 +0200
++++ b/vboxnetflt/include/VBox/intnet.h 2011-09-06 15:54:05.424565524 +0200
+@@ -783,7 +783,7 @@ typedef struct INTNETTRUNKFACTORY
+ DECLR0CALLBACKMEMBER(int, pfnCreateAndConnect,(struct INTNETTRUNKFACTORY *pIfFactory, const char *pszName,
+ PINTNETTRUNKSWPORT pSwitchPort, uint32_t fFlags,
+ PINTNETTRUNKIFPORT *ppIfPort));
+-} INTNETTRUNKFACTORY;
++} __no_const INTNETTRUNKFACTORY;
+ /** Pointer to the trunk factory. */
+ typedef INTNETTRUNKFACTORY *PINTNETTRUNKFACTORY;
+
+diff -urp vboxnetflt.orig/linux/VBoxNetFlt-linux.c vboxnetflt/linux/VBoxNetFlt-linux.c
+--- a/vboxnetflt.orig/linux/VBoxNetFlt-linux.c 2011-07-19 12:15:22.000000000 +0200
++++ b/vboxnetflt/linux/VBoxNetFlt-linux.c 2011-09-06 15:56:00.516559379 +0200
+@@ -840,7 +840,7 @@ typedef struct ethtool_ops OVR_OPSTYPE;
+
+ # else /* LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 29) */
+
+-typedef struct net_device_ops OVR_OPSTYPE;
++typedef net_device_ops_no_const OVR_OPSTYPE;
+ # define OVR_OPS netdev_ops
+ # define OVR_XMIT pOrgOps->ndo_start_xmit
+
+diff -urp vboxpci.orig/include/VBox/rawpci.h vboxpci/include/VBox/rawpci.h
+--- a/vboxpci.orig/include/VBox/rawpci.h 2011-04-18 17:01:12.000000000 +0200
++++ b/vboxpci/include/VBox/rawpci.h 2011-09-06 15:57:17.340555277 +0200
+@@ -545,7 +545,7 @@ typedef struct RAWPCIFACTORY
+ DECLR0CALLBACKMEMBER(void, pfnDeinitVm,(PRAWPCIFACTORY pFactory,
+ PVM pVM,
+ PRAWPCIPERVM pPciData));
+-} RAWPCIFACTORY;
++} __no_const RAWPCIFACTORY;
+
+ #define RAWPCIFACTORY_UUID_STR "ea089839-4171-476f-adfb-9e7ab1cbd0fb"
+