aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro Filipe <xpecex@outlook.com>2018-10-02 20:12:39 -0300
committerJakub Jirutka <jakub@jirutka.cz>2018-10-04 01:37:12 +0200
commite1a6f85774be7d0bd6d75468972e2705e96f971d (patch)
tree25746e3207daaf4547ff27d08179b69c943dcf1d
parent929916e709462e7561283e51e9eb3605f096975f (diff)
downloadaports-e1a6f85774be7d0bd6d75468972e2705e96f971d.tar.bz2
aports-e1a6f85774be7d0bd6d75468972e2705e96f971d.tar.xz
testing/ameba: upgrade to 0.8.0
-rw-r--r--testing/ameba/APKBUILD8
-rw-r--r--testing/ameba/fix-makefile.patch14
2 files changed, 11 insertions, 11 deletions
diff --git a/testing/ameba/APKBUILD b/testing/ameba/APKBUILD
index 0bd664f218..354434f777 100644
--- a/testing/ameba/APKBUILD
+++ b/testing/ameba/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ameba
-pkgver=0.5.0
+pkgver=0.8.0
pkgrel=0
pkgdesc="A static code analysis tool for Crystal"
-url="https://github.com/veelenga/ameba"
+url="https://veelenga.github.io/ameba/"
arch="x86_64" # limited by crystal. build fails on aarch64
license="MIT"
makedepends="crystal libxml2-dev shards yaml-dev"
@@ -29,5 +29,5 @@ package() {
make install PREFIX="$pkgdir/usr"
}
-sha512sums="12498c3ea90ee1c31ce7f45b3addf7bc1fb192223eaca4fb1e80483272f4695175cec40be6c6d3d3b8b61113c0e625e65ac0845b7ea14de2bab51f91473d7522 ameba-0.5.0.tar.gz
-dde379039eebda0ea67e5a95d74af0980b316b77ca7ac426e307578358030702488a6e1e7ba70b490a5aa1eb53e144ad348cb4d75717b3601f8e8ea73b36a5fa fix-makefile.patch"
+sha512sums="5ee602374f7b3c7241bfe16d0afeb74af5acf5b3530d8cac3b3b59c8c9b39e017bec018b04bdb79d973cd473ed84c07a7d8e8ed376d1f0c7ecff9a3fe48971c6 ameba-0.8.0.tar.gz
+0acb42fe00c650b801f88911457e3d83f7297719494094e8687b67093d5641b6f892d63c603fd2d346a8db06128158ae4ace3a8a9bd5852b838c6a4d6104e9d6 fix-makefile.patch"
diff --git a/testing/ameba/fix-makefile.patch b/testing/ameba/fix-makefile.patch
index a2ed851d74..10d0b7308b 100644
--- a/testing/ameba/fix-makefile.patch
+++ b/testing/ameba/fix-makefile.patch
@@ -1,17 +1,16 @@
--- a/Makefile
+++ b/Makefile
-@@ -2,16 +2,19 @@
+@@ -3,17 +3,19 @@
PREFIX ?= /usr/local
SHARD_BIN ?= ../../bin
--build:
+.PHONY: build
-+build: bin/ameba
+ build: bin/ameba
+
-+bin/ameba:
- $(CRYSTAL_BIN) build --no-debug -o bin/ameba src/cli.cr $(CRFLAGS)
+ bin/ameba:
+ $(SHARDS_BIN) build $(CRFLAGS)
clean:
- rm -f ./bin/ameba
+ rm -f ./bin/ameba ./bin/ameba.dwarf
-install: build
+install: bin/ameba
mkdir -p $(PREFIX)/bin
@@ -24,4 +23,5 @@
- $(CRYSTAL_BIN) spec
+test: bin/ameba
+ $(CRYSTAL_BIN) spec $(SPEC_FLAGS)
- ./bin/ameba
+ ./bin/ameba --all
+