aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames White <stegoxorus@gmail.com>2018-08-30 22:03:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-05 20:12:09 +0000
commitf084cbc1f5b8f007461251a87e37c7669cfef2ad (patch)
tree21b3d84e0bd1522bf45840ef103769619ada2bc9
parent88174c8071e4247ec4c144f121058dd19edceb24 (diff)
downloadaports-f084cbc1f5b8f007461251a87e37c7669cfef2ad.tar.bz2
aports-f084cbc1f5b8f007461251a87e37c7669cfef2ad.tar.xz
testing/py-h5py: new aport
https://www.h5py.org Read and write HDF5 files from Python
-rw-r--r--testing/py-h5py/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/py-h5py/APKBUILD b/testing/py-h5py/APKBUILD
new file mode 100644
index 0000000000..9eb744da97
--- /dev/null
+++ b/testing/py-h5py/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: James White <stegoxorus@gmail.com>
+# Maintainer: James White <stegoxorus@gmail.com>
+pkgname=py-h5py
+_pkgname=h5py
+pkgver=2.8.0
+pkgrel=0
+pkgdesc="Read and write HDF5 files from Python"
+url="https://www.h5py.org"
+arch="all"
+license="BSD"
+depends="py-six py-numpy hdf5"
+makedepends="cython-dev python2-dev python3-dev hdf5-dev py-setuptools py-numpy-dev py-six"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ replaces="$pkgname"
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="670b80727c7a0b53018a5f8bb0bceedf9634fe9400fc3080954eaad5329d544c57c49177d02236a243a09ce3e638b10caeceb1cc572d03c87f227888a4430039 h5py-2.8.0.tar.gz"