aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-08 12:49:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-09 12:37:45 +0000
commit02ec3c8c845f2a6a3700e50c5c1bdacda02f21b9 (patch)
treeec796b9b4eba12576b114ac49da08bb737c56e67
parente629a5197e66984eb1d2888be831a1eb4c20ee87 (diff)
downloadaports-02ec3c8c845f2a6a3700e50c5c1bdacda02f21b9.tar.bz2
aports-02ec3c8c845f2a6a3700e50c5c1bdacda02f21b9.tar.xz
community/libpsl: new aport
needed by libsoup
-rw-r--r--community/libpsl/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/libpsl/APKBUILD b/community/libpsl/APKBUILD
new file mode 100644
index 0000000000..2e8964b485
--- /dev/null
+++ b/community/libpsl/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libpsl
+pkgver=0.20.2
+pkgrel=0
+pkgdesc="C library for the Publix Suffix List"
+url="https://rockdaboot.github.io/libpsl"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/rockdaboot/libpsl/releases/download/libpsl-$pkgver/libpsl-$pkgver.tar.gz"
+builddir="$srcdir/libpsl-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="fa9f6f7f0447d9fe00f5dfca5262c56ff26217eea44d0f7fc1e5d982224c41874e753f0aa06dd9e5d7d03d4f04e3dacd4f36034cc8dd0fc6e2c28b49a23e62fe libpsl-0.20.2.tar.gz"