aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-10-18 00:04:51 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-10-18 00:05:55 +0200
commit0666c3405e078562e5e6cefc77d45e8cc91092bc (patch)
tree8f24bc3ecdafcfe571a437e3e5bf3a04806993e9
parent802ed770cf6925a93edc86bd13f302a6864a8bc6 (diff)
downloadaports-0666c3405e078562e5e6cefc77d45e8cc91092bc.tar.bz2
aports-0666c3405e078562e5e6cefc77d45e8cc91092bc.tar.xz
main/ruby: upgrade to 2.5.2
-rw-r--r--main/ruby/APKBUILD22
-rw-r--r--main/ruby/libressl-2.7.patch33
2 files changed, 14 insertions, 41 deletions
diff --git a/main/ruby/APKBUILD b/main/ruby/APKBUILD
index ab2509e4ac..3d5cd45e03 100644
--- a/main/ruby/APKBUILD
+++ b/main/ruby/APKBUILD
@@ -3,6 +3,9 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
#
# secfixes:
+# 2.5.2-r0:
+# - CVE-2018-16395
+# - CVE-2018-16396
# 2.5.1-r0:
# - CVE-2017-17742
# - CVE-2018-6914
@@ -23,9 +26,9 @@
# - CVE-2017-17405
#
pkgname=ruby
-pkgver=2.5.1
+pkgver=2.5.2
_abiver="${pkgver%.*}.0"
-pkgrel=2
+pkgrel=0
pkgdesc="An object-oriented language for quick and easy programming"
url="http://www.ruby-lang.org/en/"
arch="all"
@@ -61,7 +64,6 @@ source="https://cache.ruby-lang.org/pub/$pkgname/${pkgver%.*}/$pkgname-$pkgver.t
rubygems-avoid-platform-specific-gems.patch
test_insns-lower-recursion-depth.patch
fix-get_main_stack.patch
- libressl-2.7.patch
"
replaces="ruby-gems"
builddir="$srcdir/$pkgname-$pkgver"
@@ -87,6 +89,13 @@ prepare() {
default_prepare
cd "$builddir"
+
+ # XXX: Fix broken symlinks pointing to nowhere.
+ rm tool/config.sub tool/config.guess
+ touch tool/config.sub tool/config.guess
+ update_config_sub
+ update_config_guess
+
autoconf
}
@@ -135,8 +144,6 @@ package() {
install -m 644 -D COPYING \
"$pkgdir"/usr/share/licenses/$pkgname/COPYING
- rm -R "$pkgdir"$_gemdir/cache/*
-
if [ -d "$pkgdir"/usr/local ]; then
local f=$(cd "$pkgdir" ; find usr/local -type f)
if [ -n "$f" ]; then
@@ -332,8 +339,7 @@ _mvgem() {
done
}
-sha512sums="67badcd96fd3808cafd6bc86c970cd83aee7e5ec682f34e7353663d96211a6af314a4c818e537ec8ca51fbc0737aac4e28e0ebacf1a4d1e13db558b623a0f6b1 ruby-2.5.1.tar.gz
+sha512sums="9aee69d2ac6aefe2d81649055ba7b99e4e58cf203ac75083ba1b35b3a4fd7f72ee257e26ca80460da5c2a7817fd507aecec9c143f170e16980625e95eeb31686 ruby-2.5.2.tar.gz
cfdc5ea3b2e2ea69c51f38e8e2180cb1dc27008ca55cc6301f142ebafdbab31c3379b3b6bba9ff543153876dd98ed2ad194df3255b7ea77a62e931c935f80538 rubygems-avoid-platform-specific-gems.patch
814fe6359505b70d8ff680adf22f20a74b4dbd3fecc9a63a6c2456ee9824257815929917b6df5394ed069a6869511b8c6dce5b95b4acbbb7867c1f3a975a0150 test_insns-lower-recursion-depth.patch
-8d730f02f76e53799f1c220eb23e3d2305940bb31216a7ab1e42d3256149c0721c7d173cdbfe505023b1af2f5cb3faa233dcc1b5d560fa8f980c17c2d29a9d81 fix-get_main_stack.patch
-fc789c840af7812ce1796470e77f71cb321e1d74b2bce97a11b5b63db7f6f0fd23576acfa193e425a51e52c0aef1ab9157e4e8a54eef7d59e02541e844055b28 libressl-2.7.patch"
+8d730f02f76e53799f1c220eb23e3d2305940bb31216a7ab1e42d3256149c0721c7d173cdbfe505023b1af2f5cb3faa233dcc1b5d560fa8f980c17c2d29a9d81 fix-get_main_stack.patch"
diff --git a/main/ruby/libressl-2.7.patch b/main/ruby/libressl-2.7.patch
deleted file mode 100644
index dab23a7588..0000000000
--- a/main/ruby/libressl-2.7.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 75de15ddcdab6efe7faf3ca1f6b5c6e5b6ba57cc Mon Sep 17 00:00:00 2001
-From: Kazuki Yamaguchi <k@rhe.jp>
-Date: Sat, 24 Mar 2018 01:44:37 +0900
-Subject: [PATCH] extconf.rb: fix build with LibreSSL 2.7.0
-
-Our compat implementation of accessor functions that were introduced in
-OpenSSL 1.1.0 conflicts with those from LibreSSL 2.7.0. Use the
-HAVE_OPAQUE_OPENSSL code path when LibreSSL 2.7 or newer is detected.
-
-Fix suggested by Joel Sing.
-
-Fixes: https://github.com/ruby/openssl/issues/192
----
- ext/openssl/extconf.rb | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/ext/openssl/extconf.rb b/ext/openssl/extconf.rb
-index 75da65cd..998d9104 100644
---- a/ext/openssl/extconf.rb
-+++ b/ext/openssl/extconf.rb
-@@ -157,8 +157,11 @@ def find_openssl_library
- have_func("SSL_is_server")
-
- # added in 1.1.0
-+if !have_struct_member("SSL", "ctx", "openssl/ssl.h") ||
-+ try_static_assert("LIBRESSL_VERSION_NUMBER >= 0x2070000fL", "openssl/opensslv.h")
-+ $defs.push("-DHAVE_OPAQUE_OPENSSL")
-+end
- have_func("CRYPTO_lock") || $defs.push("-DHAVE_OPENSSL_110_THREADING_API")
--have_struct_member("SSL", "ctx", "openssl/ssl.h") || $defs.push("-DHAVE_OPAQUE_OPENSSL")
- have_func("BN_GENCB_new")
- have_func("BN_GENCB_free")
- have_func("BN_GENCB_get_arg")