aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-05-23 15:22:15 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-05-23 15:22:15 +0200
commit2604d2f13b95a35836fe9d8a7e733635300c346c (patch)
treeda56146fda1300d9a06717f1e9359f92d1ddbd4d
parentce44a928921cd0c87be29f2fc6aa10d200456aab (diff)
downloadaports-2604d2f13b95a35836fe9d8a7e733635300c346c.tar.bz2
aports-2604d2f13b95a35836fe9d8a7e733635300c346c.tar.xz
main/lxc: fix lxc-bridge config
-rw-r--r--main/lxc/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/main/lxc/APKBUILD b/main/lxc/APKBUILD
index 381d4c832c..6e3185bd20 100644
--- a/main/lxc/APKBUILD
+++ b/main/lxc/APKBUILD
@@ -5,7 +5,7 @@
pkgname=lxc
pkgver=2.0.7
_pkgver=${pkgver/_rc/.rc}
-pkgrel=3
+pkgrel=4
pkgdesc="Userspace interface for the Linux kernel containment features"
url="https://linuxcontainers.org/lxc/"
arch="all"
@@ -127,7 +127,7 @@ bridge() {
"$subpkgdir"/etc/lxc
ln -s dnsmasq "$subpkgdir"/etc/init.d/dnsmasq.lxcbr0
- cat ->>"$subpkgdir"/etc/conf.d/dnsmasq.lxcbr0 <<EOF
+ cat >>"$subpkgdir"/etc/conf.d/dnsmasq.lxcbr0 <<- EOF
BRIDGE_ADDR="10.0.3.1"
BRIDGE_NETMASK="255.255.255.0"
BRIDGE_NETWORK="10.0.3.0/24"
@@ -136,12 +136,12 @@ bridge() {
BRIDGE_MAC="00:16:3e:00:00:00"
DNSMASQ_CONFFILE="/etc/lxc/dnsmasq.conf"
EOF
- cat ->>"$subpkgdir"/etc/lxc/dnsmasq.conf <<EOF
+ cat >>"$subpkgdir"/etc/lxc/dnsmasq.conf <<- EOF
#dhcp-host=somehost,10.0.3.3
#dhcp-host=otherhost,10.0.3.4
EOF
- cat ->>"$subpkgdir"/etc/conf.d/lxc <<EOF
- rc_need="lxc-bridge"
+ cat >>"$subpkgdir"/etc/conf.d/lxc <<- EOF
+ rc_need="dnsmasq.lxcbr0"
EOF
}