aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2018-10-09 11:34:49 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-15 07:08:05 +0000
commit262b63aa314a96702380bdbbfef574d1f79526a1 (patch)
treee1ec44cf4f75d0850ccb30d91deb2c5b18fffbac
parent9294d355aed9f8b230862d5fe7ba373871c16b79 (diff)
downloadaports-262b63aa314a96702380bdbbfef574d1f79526a1.tar.bz2
aports-262b63aa314a96702380bdbbfef574d1f79526a1.tar.xz
community/xbps: upgrade to 0.53
-rw-r--r--community/xbps/0f338597015271ee504100c32fd2c4926efdb423.patch (renamed from community/xbps/moving-_unused-macro-to-_unused_attr.patch)535
-rw-r--r--community/xbps/APKBUILD12
2 files changed, 301 insertions, 246 deletions
diff --git a/community/xbps/moving-_unused-macro-to-_unused_attr.patch b/community/xbps/0f338597015271ee504100c32fd2c4926efdb423.patch
index 0e01025e8a..6d056cc3d5 100644
--- a/community/xbps/moving-_unused-macro-to-_unused_attr.patch
+++ b/community/xbps/0f338597015271ee504100c32fd2c4926efdb423.patch
@@ -1,152 +1,103 @@
-From: Breno Leitao <breno.leitao@gmail.com>
-Date: Tue, 4 Apr 2017 19:20:02 +0000
-Last-Updated: Mon, 21 May 2018 15:24:35 +0000
-Subject: [PATCH] Moving _unused macro to _unused_attr
+From 0f338597015271ee504100c32fd2c4926efdb423 Mon Sep 17 00:00:00 2001
+From: Foxlet <foxlet@furcode.co>
+Date: Tue, 17 Jul 2018 22:24:26 -0400
+Subject: [PATCH] Fix namespace violation
-Currently xbps package fails to build on ppc64le using musl libc because
-the signal.h header includes a struct field called _unused, that becomes
-defined as an function attribute due to the a CFLAG -D macro definition.
-This cause the build to fail.
+---
+ bin/xbps-alternatives/main.c | 2 +-
+ bin/xbps-create/main.c | 4 +--
+ bin/xbps-install/main.c | 4 +--
+ bin/xbps-install/state_cb.c | 2 +-
+ bin/xbps-pkgdb/check.c | 6 ++---
+ bin/xbps-pkgdb/check_pkg_unneeded.c | 2 +-
+ bin/xbps-query/list.c | 38 ++++++++++++++---------------
+ bin/xbps-query/ownedby.c | 10 ++++----
+ bin/xbps-query/search.c | 8 +++---
+ bin/xbps-reconfigure/main.c | 2 +-
+ bin/xbps-remove/clean-cache.c | 4 +--
+ bin/xbps-remove/main.c | 2 +-
+ bin/xbps-rindex/index-clean.c | 4 +--
+ bin/xbps-rindex/remove-obsoletes.c | 2 +-
+ bin/xbps-uchroot/main.c | 4 +--
+ configure | 2 +-
+ lib/package_orphans.c | 2 +-
+ lib/plist_fetch.c | 6 ++---
+ lib/rpool.c | 6 ++---
+ lib/transaction_conflicts.c | 2 +-
+ 20 files changed, 56 insertions(+), 56 deletions(-)
-This patch just rename _unused macro to _unused_attr in order to avoid the
-names being clashed.
-
---- a/lib/package_orphans.c
-+++ b/lib/package_orphans.c
-@@ -60,7 +60,7 @@
- */
-
- xbps_array_t
--xbps_find_pkg_orphans(struct xbps_handle *xhp, xbps_array_t orphans_user _unused)
-+xbps_find_pkg_orphans(struct xbps_handle *xhp, xbps_array_t orphans_user _unused_attr)
- {
- xbps_array_t rdeps, reqby, array = NULL;
- xbps_dictionary_t pkgd, deppkgd;
---- a/lib/rpool.c
-+++ b/lib/rpool.c
-@@ -120,7 +120,7 @@
- }
-
- void
--xbps_rpool_release(struct xbps_handle *xhp _unused)
-+xbps_rpool_release(struct xbps_handle *xhp _unused_attr)
- {
- struct xbps_repo *repo;
-
-@@ -195,7 +195,7 @@
- }
-
- static int
--find_pkg_revdeps_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
-+find_pkg_revdeps_cb(struct xbps_repo *repo, void *arg, bool *done _unused_attr)
- {
- struct rpool_fpkg *rpf = arg;
- xbps_array_t revdeps = NULL;
-@@ -216,7 +216,7 @@
- }
-
- static int
--find_best_pkg_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
-+find_best_pkg_cb(struct xbps_repo *repo, void *arg, bool *done _unused_attr)
- {
- struct rpool_fpkg *rpf = arg;
- xbps_dictionary_t pkgd;
---- a/lib/plist_fetch.c
-+++ b/lib/plist_fetch.c
-@@ -46,7 +46,7 @@
- };
-
- static int
--fetch_archive_open(struct archive *a _unused, void *client_data)
-+fetch_archive_open(struct archive *a _unused_attr, void *client_data)
- {
- struct fetch_archive *f = client_data;
-
-@@ -59,7 +59,7 @@
- }
-
- static ssize_t
--fetch_archive_read(struct archive *a _unused, void *client_data, const void **buf)
-+fetch_archive_read(struct archive *a _unused_attr, void *client_data, const void **buf)
- {
- struct fetch_archive *f = client_data;
-
-@@ -68,7 +68,7 @@
+diff --git a/bin/xbps-alternatives/main.c b/bin/xbps-alternatives/main.c
+index c722a74b..94ab31e8 100644
+--- a/bin/xbps-alternatives/main.c
++++ b/bin/xbps-alternatives/main.c
+@@ -55,7 +55,7 @@ usage(bool fail)
}
static int
--fetch_archive_close(struct archive *a _unused, void *client_data)
-+fetch_archive_close(struct archive *a _unused_attr, void *client_data)
+-state_cb(const struct xbps_state_cb_data *xscd, void *cbd _unused)
++state_cb(const struct xbps_state_cb_data *xscd, void *cbd UNUSED)
{
- struct fetch_archive *f = client_data;
-
---- a/lib/transaction_conflicts.c
-+++ b/lib/transaction_conflicts.c
-@@ -148,7 +148,7 @@
+ bool slog = false;
- static int
- pkgdb_conflicts_cb(struct xbps_handle *xhp, xbps_object_t obj,
-- const char *key _unused, void *arg, bool *done _unused)
-+ const char *key _unused_attr, void *arg, bool *done _unused_attr)
- {
- xbps_array_t pkg_cflicts, trans_cflicts, pkgs = arg;
- xbps_dictionary_t pkgd;
+diff --git a/bin/xbps-create/main.c b/bin/xbps-create/main.c
+index aac9676a..2c211215 100644
--- a/bin/xbps-create/main.c
+++ b/bin/xbps-create/main.c
-@@ -187,7 +187,7 @@
+@@ -199,7 +199,7 @@ process_one_alternative(const char *altgrname, const char *val)
static void
-process_dict_of_arrays(const char *key _unused, const char *val)
-+process_dict_of_arrays(const char *key _unused_attr, const char *val)
++process_dict_of_arrays(const char *key UNUSED, const char *val)
{
char *altgrname, *args, *p, *saveptr;
-@@ -290,7 +290,7 @@
+@@ -302,7 +302,7 @@ entry_is_conf_file(const char *file)
}
static int
--ftw_cb(const char *fpath, const struct stat *sb, int type, struct FTW *ftwbuf _unused)
-+ftw_cb(const char *fpath, const struct stat *sb, int type, struct FTW *ftwbuf _unused_attr)
+-ftw_cb(const char *fpath, const struct stat *sb, const struct dirent *dir _unused)
++ftw_cb(const char *fpath, const struct stat *sb, const struct dirent *dir UNUSED)
{
+ struct xentry *xe = NULL;
xbps_dictionary_t fileinfo = NULL;
- const char *filep = NULL;
---- a/bin/xbps-rindex/index-clean.c
-+++ b/bin/xbps-rindex/index-clean.c
-@@ -43,9 +43,9 @@
- static int
- idx_cleaner_cb(struct xbps_handle *xhp,
- xbps_object_t obj,
-- const char *key _unused,
-+ const char *key _unused_attr,
- void *arg,
-- bool *done _unused)
-+ bool *done _unused_attr)
+diff --git a/bin/xbps-install/main.c b/bin/xbps-install/main.c
+index b57f2fe9..da20da1a 100644
+--- a/bin/xbps-install/main.c
++++ b/bin/xbps-install/main.c
+@@ -68,7 +68,7 @@ usage(bool fail)
+ }
+
+ static void
+-unpack_progress_cb(const struct xbps_unpack_cb_data *xpd, void *cbdata _unused)
++unpack_progress_cb(const struct xbps_unpack_cb_data *xpd, void *cbdata UNUSED)
{
- const char *repourl = arg;
- const char *arch, *pkgver, *sha256;
---- a/bin/xbps-rindex/remove-obsoletes.c
-+++ b/bin/xbps-rindex/remove-obsoletes.c
-@@ -65,7 +65,7 @@
+ if (xpd->entry == NULL || xpd->entry_total_count <= 0)
+ return;
+@@ -80,7 +80,7 @@ unpack_progress_cb(const struct xbps_unpack_cb_data *xpd, void *cbdata _unused)
}
static int
--cleaner_cb(struct xbps_handle *xhp, xbps_object_t obj, const char *key _unused, void *arg, bool *done _unused)
-+cleaner_cb(struct xbps_handle *xhp, xbps_object_t obj, const char *key _unused_attr, void *arg, bool *done _unused_attr)
+-repo_import_key_cb(struct xbps_repo *repo, void *arg _unused, bool *done _unused)
++repo_import_key_cb(struct xbps_repo *repo, void *arg UNUSED, bool *done UNUSED)
{
- struct xbps_repo *repo = ((struct xbps_repo **)arg)[0], *stage = ((struct xbps_repo **)arg)[1];
- const char *binpkg;
---- a/bin/xbps-pkgdb/check_pkg_unneeded.c
-+++ b/bin/xbps-pkgdb/check_pkg_unneeded.c
-@@ -43,7 +43,7 @@
- * and remove them if that was true.
- */
+ int rv;
+
+diff --git a/bin/xbps-install/state_cb.c b/bin/xbps-install/state_cb.c
+index 5189b9a9..a2063cea 100644
+--- a/bin/xbps-install/state_cb.c
++++ b/bin/xbps-install/state_cb.c
+@@ -32,7 +32,7 @@
+ #include "defs.h"
+
int
--check_pkg_unneeded(struct xbps_handle *xhp _unused, const char *pkgname, void *arg)
-+check_pkg_unneeded(struct xbps_handle *xhp _unused_attr, const char *pkgname, void *arg)
+-state_cb(const struct xbps_state_cb_data *xscd, void *cbdata _unused)
++state_cb(const struct xbps_state_cb_data *xscd, void *cbdata UNUSED)
{
- xbps_array_t replaces;
- xbps_dictionary_t pkgd = arg;
+ xbps_dictionary_t pkgd;
+ const char *instver, *newver;
+diff --git a/bin/xbps-pkgdb/check.c b/bin/xbps-pkgdb/check.c
+index ed393398..6ae11db7 100644
--- a/bin/xbps-pkgdb/check.c
+++ b/bin/xbps-pkgdb/check.c
@@ -36,11 +36,11 @@
@@ -154,232 +105,200 @@ names being clashed.
static int
-pkgdb_cb(struct xbps_handle *xhp _unused,
-+pkgdb_cb(struct xbps_handle *xhp _unused_attr,
++pkgdb_cb(struct xbps_handle *xhp UNUSED,
xbps_object_t obj,
- const char *key _unused,
-+ const char *key _unused_attr,
++ const char *key UNUSED,
void *arg,
- bool *done _unused)
-+ bool *done _unused_attr)
++ bool *done UNUSED)
{
const char *pkgver;
char *pkgname;
+diff --git a/bin/xbps-pkgdb/check_pkg_unneeded.c b/bin/xbps-pkgdb/check_pkg_unneeded.c
+index d2249304..2b137b3f 100644
+--- a/bin/xbps-pkgdb/check_pkg_unneeded.c
++++ b/bin/xbps-pkgdb/check_pkg_unneeded.c
+@@ -43,7 +43,7 @@
+ * and remove them if that was true.
+ */
+ int
+-check_pkg_unneeded(struct xbps_handle *xhp _unused, const char *pkgname, void *arg)
++check_pkg_unneeded(struct xbps_handle *xhp UNUSED, const char *pkgname, void *arg)
+ {
+ xbps_array_t replaces;
+ xbps_dictionary_t pkgd = arg;
+diff --git a/bin/xbps-query/list.c b/bin/xbps-query/list.c
+index ddda8be8..f08334c3 100644
--- a/bin/xbps-query/list.c
+++ b/bin/xbps-query/list.c
-@@ -38,11 +38,11 @@
+@@ -38,11 +38,11 @@ struct list_pkgver_cb {
};
int
-list_pkgs_in_dict(struct xbps_handle *xhp _unused,
-+list_pkgs_in_dict(struct xbps_handle *xhp _unused_attr,
++list_pkgs_in_dict(struct xbps_handle *xhp UNUSED,
xbps_object_t obj,
- const char *key _unused,
-+ const char *key _unused_attr,
++ const char *key UNUSED,
void *arg,
- bool *loop_done _unused)
-+ bool *loop_done _unused_attr)
++ bool *loop_done UNUSED)
{
struct list_pkgver_cb *lpc = arg;
const char *pkgver, *short_desc, *state_str;
-@@ -88,11 +88,11 @@
+@@ -88,11 +88,11 @@ list_pkgs_in_dict(struct xbps_handle *xhp _unused,
}
int
-list_manual_pkgs(struct xbps_handle *xhp _unused,
-+list_manual_pkgs(struct xbps_handle *xhp _unused_attr,
++list_manual_pkgs(struct xbps_handle *xhp UNUSED,
xbps_object_t obj,
- const char *key _unused,
- void *arg _unused,
- bool *loop_done _unused)
-+ const char *key _unused_attr,
-+ void *arg _unused_attr,
-+ bool *loop_done _unused_attr)
++ const char *key UNUSED,
++ void *arg UNUSED,
++ bool *loop_done UNUSED)
{
const char *pkgver;
bool automatic = false;
-@@ -107,11 +107,11 @@
+@@ -107,11 +107,11 @@ list_manual_pkgs(struct xbps_handle *xhp _unused,
}
int
-list_hold_pkgs(struct xbps_handle *xhp _unused,
-+list_hold_pkgs(struct xbps_handle *xhp _unused_attr,
++list_hold_pkgs(struct xbps_handle *xhp UNUSED,
xbps_object_t obj,
- const char *key _unused,
- void *arg _unused,
- bool *loop_done _unused)
-+ const char *key _unused_attr,
-+ void *arg _unused_attr,
-+ bool *loop_done _unused_attr)
++ const char *key UNUSED,
++ void *arg UNUSED,
++ bool *loop_done UNUSED)
{
const char *pkgver;
-@@ -124,11 +124,11 @@
+@@ -124,11 +124,11 @@ list_hold_pkgs(struct xbps_handle *xhp _unused,
}
int
-list_repolock_pkgs(struct xbps_handle *xhp _unused,
-+list_repolock_pkgs(struct xbps_handle *xhp _unused_attr,
++list_repolock_pkgs(struct xbps_handle *xhp UNUSED,
xbps_object_t obj,
- const char *key _unused,
- void *arg _unused,
- bool *loop_done _unused)
-+ const char *key _unused_attr,
-+ void *arg _unused_attr,
-+ bool *loop_done _unused_attr)
++ const char *key UNUSED,
++ void *arg UNUSED,
++ bool *loop_done UNUSED)
{
const char *pkgver;
-@@ -171,7 +171,7 @@
+@@ -171,7 +171,7 @@ list_pkgs_pkgdb(struct xbps_handle *xhp)
}
static int
-repo_list_uri_cb(struct xbps_repo *repo, void *arg _unused, bool *done _unused)
-+repo_list_uri_cb(struct xbps_repo *repo, void *arg _unused_attr, bool *done _unused_attr)
++repo_list_uri_cb(struct xbps_repo *repo, void *arg UNUSED, bool *done UNUSED)
{
const char *signedby = NULL;
uint16_t pubkeysize = 0;
-@@ -219,11 +219,11 @@
+@@ -219,11 +219,11 @@ struct fflongest {
};
static int
-_find_longest_pkgver_cb(struct xbps_handle *xhp _unused,
-+_find_longest_pkgver_cb(struct xbps_handle *xhp _unused_attr,
++_find_longest_pkgver_cb(struct xbps_handle *xhp UNUSED,
xbps_object_t obj,
- const char *key _unused,
-+ const char *key _unused_attr,
++ const char *key UNUSED,
void *arg,
- bool *loop_done _unused)
-+ bool *loop_done _unused_attr)
++ bool *loop_done UNUSED)
{
struct fflongest *ffl = arg;
const char *pkgver;
---- a/bin/xbps-query/search.c
-+++ b/bin/xbps-query/search.c
-@@ -94,11 +94,11 @@
- }
-
- static int
--search_array_cb(struct xbps_handle *xhp _unused,
-+search_array_cb(struct xbps_handle *xhp _unused_attr,
- xbps_object_t obj,
-- const char *key _unused,
-+ const char *key _unused_attr,
- void *arg,
-- bool *done _unused)
-+ bool *done _unused_attr)
- {
- xbps_object_t obj2;
- struct search_data *sd = arg;
-@@ -210,7 +210,7 @@
- }
-
- static int
--search_repo_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
-+search_repo_cb(struct xbps_repo *repo, void *arg, bool *done _unused_attr)
- {
- xbps_array_t allkeys;
- struct search_data *sd = arg;
+diff --git a/bin/xbps-query/ownedby.c b/bin/xbps-query/ownedby.c
+index fc8684dc..11f76a99 100644
--- a/bin/xbps-query/ownedby.c
+++ b/bin/xbps-query/ownedby.c
-@@ -97,9 +97,9 @@
+@@ -97,9 +97,9 @@ match_files_by_pattern(xbps_dictionary_t pkg_filesd,
static int
ownedby_pkgdb_cb(struct xbps_handle *xhp,
xbps_object_t obj,
- const char *obj_key _unused,
-+ const char *obj_key _unused_attr,
++ const char *obj_key UNUSED,
void *arg,
- bool *done _unused)
-+ bool *done _unused_attr)
++ bool *done UNUSED)
{
xbps_dictionary_t pkgmetad;
xbps_array_t files_keys;
-@@ -129,9 +129,9 @@
+@@ -129,9 +129,9 @@ ownedby_pkgdb_cb(struct xbps_handle *xhp,
static int
repo_match_cb(struct xbps_handle *xhp,
xbps_object_t obj,
- const char *key _unused,
-+ const char *key _unused_attr,
++ const char *key UNUSED,
void *arg,
- bool *done _unused)
-+ bool *done _unused_attr)
++ bool *done UNUSED)
{
xbps_dictionary_t filesd;
xbps_array_t files_keys;
-@@ -163,7 +163,7 @@
+@@ -163,7 +163,7 @@ repo_match_cb(struct xbps_handle *xhp,
}
static int
-repo_ownedby_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
-+repo_ownedby_cb(struct xbps_repo *repo, void *arg, bool *done _unused_attr)
++repo_ownedby_cb(struct xbps_repo *repo, void *arg, bool *done UNUSED)
{
xbps_array_t allkeys;
struct ffdata *ffd = arg;
---- a/bin/xbps-reconfigure/main.c
-+++ b/bin/xbps-reconfigure/main.c
-@@ -52,7 +52,7 @@
+diff --git a/bin/xbps-query/search.c b/bin/xbps-query/search.c
+index 4b7ef054..41e1211d 100644
+--- a/bin/xbps-query/search.c
++++ b/bin/xbps-query/search.c
+@@ -94,11 +94,11 @@ print_results(struct xbps_handle *xhp, struct search_data *sd)
}
static int
--state_cb(const struct xbps_state_cb_data *xscd, void *cbd _unused)
-+state_cb(const struct xbps_state_cb_data *xscd, void *cbd _unused_attr)
- {
- bool slog = false;
-
---- a/bin/xbps-install/state_cb.c
-+++ b/bin/xbps-install/state_cb.c
-@@ -32,7 +32,7 @@
- #include "defs.h"
-
- int
--state_cb(const struct xbps_state_cb_data *xscd, void *cbdata _unused)
-+state_cb(const struct xbps_state_cb_data *xscd, void *cbdata _unused_attr)
- {
- xbps_dictionary_t pkgd;
- const char *instver, *newver;
---- a/bin/xbps-install/main.c
-+++ b/bin/xbps-install/main.c
-@@ -68,7 +68,7 @@
- }
-
- static void
--unpack_progress_cb(const struct xbps_unpack_cb_data *xpd, void *cbdata _unused)
-+unpack_progress_cb(const struct xbps_unpack_cb_data *xpd, void *cbdata _unused_attr)
+-search_array_cb(struct xbps_handle *xhp _unused,
++search_array_cb(struct xbps_handle *xhp UNUSED,
+ xbps_object_t obj,
+- const char *key _unused,
++ const char *key UNUSED,
+ void *arg,
+- bool *done _unused)
++ bool *done UNUSED)
{
- if (xpd->entry == NULL || xpd->entry_total_count <= 0)
- return;
-@@ -80,7 +80,7 @@
+ xbps_object_t obj2;
+ struct search_data *sd = arg;
+@@ -210,7 +210,7 @@ search_array_cb(struct xbps_handle *xhp _unused,
}
static int
--repo_import_key_cb(struct xbps_repo *repo, void *arg _unused, bool *done _unused)
-+repo_import_key_cb(struct xbps_repo *repo, void *arg _unused_attr, bool *done _unused_attr)
+-search_repo_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
++search_repo_cb(struct xbps_repo *repo, void *arg, bool *done UNUSED)
{
- int rv;
-
---- a/bin/xbps-alternatives/main.c
-+++ b/bin/xbps-alternatives/main.c
-@@ -55,7 +55,7 @@
+ xbps_array_t allkeys;
+ struct search_data *sd = arg;
+diff --git a/bin/xbps-reconfigure/main.c b/bin/xbps-reconfigure/main.c
+index 814959a8..1508c375 100644
+--- a/bin/xbps-reconfigure/main.c
++++ b/bin/xbps-reconfigure/main.c
+@@ -52,7 +52,7 @@ usage(bool fail)
}
static int
-state_cb(const struct xbps_state_cb_data *xscd, void *cbd _unused)
-+state_cb(const struct xbps_state_cb_data *xscd, void *cbd _unused_attr)
++state_cb(const struct xbps_state_cb_data *xscd, void *cbd UNUSED)
{
bool slog = false;
---- a/bin/xbps-uchroot/main.c
-+++ b/bin/xbps-uchroot/main.c
-@@ -109,8 +109,8 @@
- }
-
- static int
--ftw_cb(const char *fpath, const struct stat *sb _unused, int type,
-- struct FTW *ftwbuf _unused)
-+ftw_cb(const char *fpath, const struct stat *sb _unused_attr, int type,
-+ struct FTW *ftwbuf _unused_attr)
- {
- int sverrno = 0;
-
+diff --git a/bin/xbps-remove/clean-cache.c b/bin/xbps-remove/clean-cache.c
+index dacc9a59..b3e00622 100644
--- a/bin/xbps-remove/clean-cache.c
+++ b/bin/xbps-remove/clean-cache.c
@@ -38,8 +38,8 @@
@@ -388,30 +307,166 @@ names being clashed.
cleaner_cb(struct xbps_handle *xhp, xbps_object_t obj,
- const char *key _unused, void *arg,
- bool *done _unused)
-+ const char *key _unused_attr, void *arg,
-+ bool *done _unused_attr)
++ const char *key UNUSED, void *arg,
++ bool *done UNUSED)
{
xbps_dictionary_t repo_pkgd;
const char *binpkg, *rsha256;
+diff --git a/bin/xbps-remove/main.c b/bin/xbps-remove/main.c
+index 25554e8c..838e610b 100644
--- a/bin/xbps-remove/main.c
+++ b/bin/xbps-remove/main.c
-@@ -64,7 +64,7 @@
+@@ -64,7 +64,7 @@ usage(bool fail)
}
static int
-state_cb_rm(const struct xbps_state_cb_data *xscd, void *cbdata _unused)
-+state_cb_rm(const struct xbps_state_cb_data *xscd, void *cbdata _unused_attr)
++state_cb_rm(const struct xbps_state_cb_data *xscd, void *cbdata UNUSED)
{
bool slog = false;
+diff --git a/bin/xbps-rindex/index-clean.c b/bin/xbps-rindex/index-clean.c
+index 364d57ed..27cedd6e 100644
+--- a/bin/xbps-rindex/index-clean.c
++++ b/bin/xbps-rindex/index-clean.c
+@@ -47,9 +47,9 @@ struct CleanerCbInfo {
+ static int
+ idx_cleaner_cb(struct xbps_handle *xhp,
+ xbps_object_t obj,
+- const char *key _unused,
++ const char *key UNUSED,
+ void *arg,
+- bool *done _unused)
++ bool *done UNUSED)
+ {
+ struct CleanerCbInfo *info = arg;
+ const char *arch, *pkgver, *sha256;
+diff --git a/bin/xbps-rindex/remove-obsoletes.c b/bin/xbps-rindex/remove-obsoletes.c
+index f426fe7c..80cf2fff 100644
+--- a/bin/xbps-rindex/remove-obsoletes.c
++++ b/bin/xbps-rindex/remove-obsoletes.c
+@@ -65,7 +65,7 @@ remove_pkg(const char *repodir, const char *file)
+ }
+
+ static int
+-cleaner_cb(struct xbps_handle *xhp, xbps_object_t obj, const char *key _unused, void *arg, bool *done _unused)
++cleaner_cb(struct xbps_handle *xhp, xbps_object_t obj, const char *key UNUSED, void *arg, bool *done UNUSED)
+ {
+ struct xbps_repo *repo = ((struct xbps_repo **)arg)[0], *stage = ((struct xbps_repo **)arg)[1];
+ const char *binpkg;
+diff --git a/bin/xbps-uchroot/main.c b/bin/xbps-uchroot/main.c
+index 0ee13253..c232de8e 100644
+--- a/bin/xbps-uchroot/main.c
++++ b/bin/xbps-uchroot/main.c
+@@ -109,8 +109,8 @@ die(const char *fmt, ...)
+ }
+
+ static int
+-ftw_cb(const char *fpath, const struct stat *sb _unused, int type,
+- struct FTW *ftwbuf _unused)
++ftw_cb(const char *fpath, const struct stat *sb UNUSED, int type,
++ struct FTW *ftwbuf UNUSED)
+ {
+ int sverrno = 0;
+
+diff --git a/configure b/configure
+index 32cc5569..ebef990a 100755
--- a/configure
+++ b/configure
-@@ -192,7 +192,7 @@
+@@ -192,7 +192,7 @@ echo "CPPFLAGS += -DXBPS_SYSCONF_PATH=\\\"${ETCDIR}\\\"" >>$CONFIG_MK
echo "CPPFLAGS += -DXBPS_SYSDEFCONF_PATH=\\\"${SHAREDIR}/xbps.d\\\"" >>$CONFIG_MK
echo "CPPFLAGS += -DXBPS_VERSION=\\\"${VERSION}\\\"" >>$CONFIG_MK
echo "CPPFLAGS += -DXBPS_META_PATH=\\\"${DBDIR}\\\"" >>$CONFIG_MK
-echo "CPPFLAGS += -D_unused=\"__attribute__((__unused__))\"" >>$CONFIG_MK
-+echo "CPPFLAGS += -D_unused_attr=\"__attribute__((__unused__))\"" >>$CONFIG_MK
++echo "CPPFLAGS += -DUNUSED=\"__attribute__((__unused__))\"" >>$CONFIG_MK
if [ -d .git ]; then
_gitrev=$(git rev-parse --short HEAD)
+diff --git a/lib/package_orphans.c b/lib/package_orphans.c
+index 4a31fe1d..b908c049 100644
+--- a/lib/package_orphans.c
++++ b/lib/package_orphans.c
+@@ -60,7 +60,7 @@
+ */
+
+ xbps_array_t
+-xbps_find_pkg_orphans(struct xbps_handle *xhp, xbps_array_t orphans_user _unused)
++xbps_find_pkg_orphans(struct xbps_handle *xhp, xbps_array_t orphans_user UNUSED)
+ {
+ xbps_array_t rdeps, reqby, array = NULL;
+ xbps_dictionary_t pkgd, deppkgd;
+diff --git a/lib/plist_fetch.c b/lib/plist_fetch.c
+index a1535515..fedd8ce8 100644
+--- a/lib/plist_fetch.c
++++ b/lib/plist_fetch.c
+@@ -46,7 +46,7 @@ struct fetch_archive {
+ };
+
+ static int
+-fetch_archive_open(struct archive *a _unused, void *client_data)
++fetch_archive_open(struct archive *a UNUSED, void *client_data)
+ {
+ struct fetch_archive *f = client_data;
+
+@@ -59,7 +59,7 @@ fetch_archive_open(struct archive *a _unused, void *client_data)
+ }
+
+ static ssize_t
+-fetch_archive_read(struct archive *a _unused, void *client_data, const void **buf)
++fetch_archive_read(struct archive *a UNUSED, void *client_data, const void **buf)
+ {
+ struct fetch_archive *f = client_data;
+
+@@ -68,7 +68,7 @@ fetch_archive_read(struct archive *a _unused, void *client_data, const void **bu
+ }
+
+ static int
+-fetch_archive_close(struct archive *a _unused, void *client_data)
++fetch_archive_close(struct archive *a UNUSED, void *client_data)
+ {
+ struct fetch_archive *f = client_data;
+
+diff --git a/lib/rpool.c b/lib/rpool.c
+index 9acc1181..94af7298 100644
+--- a/lib/rpool.c
++++ b/lib/rpool.c
+@@ -120,7 +120,7 @@ xbps_rpool_get_repo(const char *url)
+ }
+
+ void
+-xbps_rpool_release(struct xbps_handle *xhp _unused)
++xbps_rpool_release(struct xbps_handle *xhp UNUSED)
+ {
+ struct xbps_repo *repo;
+
+@@ -195,7 +195,7 @@ find_pkg_cb(struct xbps_repo *repo, void *arg, bool *done)
+ }
+
+ static int
+-find_pkg_revdeps_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
++find_pkg_revdeps_cb(struct xbps_repo *repo, void *arg, bool *done UNUSED)
+ {
+ struct rpool_fpkg *rpf = arg;
+ xbps_array_t revdeps = NULL;
+@@ -216,7 +216,7 @@ find_pkg_revdeps_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
+ }
+
+ static int
+-find_best_pkg_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
++find_best_pkg_cb(struct xbps_repo *repo, void *arg, bool *done UNUSED)
+ {
+ struct rpool_fpkg *rpf = arg;
+ xbps_dictionary_t pkgd;
+diff --git a/lib/transaction_conflicts.c b/lib/transaction_conflicts.c
+index 09975cee..387895a4 100644
+--- a/lib/transaction_conflicts.c
++++ b/lib/transaction_conflicts.c
+@@ -148,7 +148,7 @@ pkg_conflicts_trans(struct xbps_handle *xhp, xbps_array_t array,
+
+ static int
+ pkgdb_conflicts_cb(struct xbps_handle *xhp, xbps_object_t obj,
+- const char *key _unused, void *arg, bool *done _unused)
++ const char *key UNUSED, void *arg, bool *done UNUSED)
+ {
+ xbps_array_t pkg_cflicts, trans_cflicts, pkgs = arg;
+ xbps_dictionary_t pkgd;
diff --git a/community/xbps/APKBUILD b/community/xbps/APKBUILD
index cd79e38e1a..1d275a77d7 100644
--- a/community/xbps/APKBUILD
+++ b/community/xbps/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=xbps
-pkgver=0.52
-pkgrel=1
+pkgver=0.53
+pkgrel=0
pkgdesc="The X Binary Package System"
arch="all"
url="https://github.com/voidlinux/xbps"
@@ -13,8 +13,8 @@ subpackages="$pkgname-dev $pkgname-doc
$pkgname-bash-completion:bashcomp:noarch
$pkgname-zsh-completion:zshcomp:noarch"
options="!check"
-source="$pkgname-$pkgver.tar.gz::https://github.com/voidlinux/$pkgname/archive/$pkgver.tar.gz
- moving-_unused-macro-to-_unused_attr.patch
+source="$pkgname-$pkgver.tar.gz::https://github.com/void-linux/$pkgname/archive/$pkgver.tar.gz
+ 0f338597015271ee504100c32fd2c4926efdb423.patch
disable-Werror.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -62,6 +62,6 @@ _submv() {
mv "$pkgdir"/$path "$subpkgdir"/${path%/*}/
}
-sha512sums="99a86abac4e8c3a7e4d6bb72c78a1c1b72592022ab0f90f794227d8fa6194a04e0411fcedc4fffb6809dcf146aa6e7f9b12e3a9854e024458f1b9c4573b7379d xbps-0.52.tar.gz
-71441115a258efff44a0768a7fb731f4f3730c4ff75279650ac93c051d49ae3153d8bdeaa534cb09681d4b2d1dfba5b9a79b0cdd30a254d84558fd8ac40d2414 moving-_unused-macro-to-_unused_attr.patch
+sha512sums="f40a479196e95cd1c01962230cd3e61f424474ceb454c3d7a31d59b636a0f17138023ae2822bb1666765f15618e3fa7e4fa48786c5530eb975f637b6abf6418f xbps-0.53.tar.gz
+5ae4fa6c5fc8d115b01d74c85121e13933b17a09404d53923a316ce7cc30325227019db33a2efe891ed2be5f61600e3003c37f07c24639ef32786d5b8d4d9c2b 0f338597015271ee504100c32fd2c4926efdb423.patch
a761edd8fd358b500337fcef79f6163ef642fc387f97d952fec0838baa786d585f21e34cd066cba1918f474bccd7decbad2587b91f125b75e308b2dfe8f4721a disable-Werror.patch"