aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-17 14:56:31 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-17 12:57:46 +0000
commit2b328d53827be5a2786e022af5accf891f0b8726 (patch)
tree2728140a1c806a7f86ad3faaf5167258862daa70
parent233e61d0881c08da221342a8fc000e9f63eda834 (diff)
downloadaports-2b328d53827be5a2786e022af5accf891f0b8726.tar.bz2
aports-2b328d53827be5a2786e022af5accf891f0b8726.tar.xz
main/linux-vanilla: fix apple keyboard
-rw-r--r--main/linux-vanilla/0001-HID-quirks-fix-support-for-Apple-Magic-Keyboards.patch35
-rw-r--r--main/linux-vanilla/APKBUILD4
2 files changed, 38 insertions, 1 deletions
diff --git a/main/linux-vanilla/0001-HID-quirks-fix-support-for-Apple-Magic-Keyboards.patch b/main/linux-vanilla/0001-HID-quirks-fix-support-for-Apple-Magic-Keyboards.patch
new file mode 100644
index 0000000000..864070e0b1
--- /dev/null
+++ b/main/linux-vanilla/0001-HID-quirks-fix-support-for-Apple-Magic-Keyboards.patch
@@ -0,0 +1,35 @@
+From 80f1d275c53464f7f8154b8d36012c1c68ab6719 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Wed, 17 Oct 2018 14:26:55 +0200
+Subject: [PATCH] HID: quirks: fix support for Apple Magic Keyboards
+
+Commit ee345492 (HID: add support for Apple Magic Keyboards) added
+support for the Magic Keyboard over Bluetooth, but did not add the
+BT_VENDOR_ID_APPLE to hid-quirks. Fix this so hid-apple driver is used
+over hid-generic.
+
+This fixes the Fn key, which does not work at all with hid-generic.
+
+Bugzilla-id: https://bugzilla.kernel.org/show_bug.cgi?id=99881
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ drivers/hid/hid-core.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/drivers/hid/hid-core.c b/drivers/hid/hid-core.c
+index 672b0be41d44..a306493e2e97 100644
+--- a/drivers/hid/hid-core.c
++++ b/drivers/hid/hid-core.c
+@@ -1964,6 +1964,9 @@ static const struct hid_device_id hid_have_special_driver[] = {
+ { HID_BLUETOOTH_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_ALU_WIRELESS_2011_ISO) },
+ { HID_BLUETOOTH_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_ALU_WIRELESS_2011_JIS) },
+ { HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_MAGIC_KEYBOARD_ANSI) },
++ { HID_BLUETOOTH_DEVICE(BT_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_MAGIC_KEYBOARD_ANSI) },
++ { HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_MAGIC_KEYBOARD_NUMPAD_ANSI) },
++ { HID_BLUETOOTH_DEVICE(BT_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_MAGIC_KEYBOARD_NUMPAD_ANSI) },
+ { HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_FOUNTAIN_TP_ONLY) },
+ { HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_GEYSER1_TP_ONLY) },
+ #endif
+--
+2.19.1
+
diff --git a/main/linux-vanilla/APKBUILD b/main/linux-vanilla/APKBUILD
index f5131f5437..684652b087 100644
--- a/main/linux-vanilla/APKBUILD
+++ b/main/linux-vanilla/APKBUILD
@@ -7,7 +7,7 @@ case $pkgver in
*.*.*) _kernver=${pkgver%.*};;
*.*) _kernver=$pkgver;;
esac
-pkgrel=0
+pkgrel=1
pkgdesc="Linux vanilla kernel"
url="http://kernel.org"
depends="mkinitfs"
@@ -17,6 +17,7 @@ options="!strip"
_config=${config:-config-vanilla.${CARCH}}
install=
source="https://cdn.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/linux-$_kernver.tar.xz
+ 0001-HID-quirks-fix-support-for-Apple-Magic-Keyboards.patch
config-vanilla.aarch64
config-vanilla.armhf
config-vanilla.x86
@@ -218,6 +219,7 @@ _dev() {
}
sha512sums="77e43a02d766c3d73b7e25c4aafb2e931d6b16e870510c22cef0cdb05c3acb7952b8908ebad12b10ef982c6efbe286364b1544586e715cf38390e483927904d8 linux-4.14.tar.xz
+421a64fc535a2091facddcc6ad4847351ccbe461f5cb57a6634d4fa78e0f4379eaf68bc43b451c026c6b07425bd7b14bc7730050f02fbe9563f6d580f9661f1b 0001-HID-quirks-fix-support-for-Apple-Magic-Keyboards.patch
2429433ce9e0bbf0a400f6e0a0bc25730a66f74d3365793063252239cfec8fcaa9af5c99d0933f0b239ec9b2e28645bbc05e7e150a90c0a481c2870a03c902e4 config-vanilla.aarch64
efb7bd5c1b380aa3db62c381c460d20a63f92260d9a6925e9839f8ccb1cce9b3531f56174b633e64a1dd1aaba43c6b23576089f7743143c52ce9301c301a538e config-vanilla.armhf
0206981c09a8a3c6f3261b0a6722324629a6d8d4da9872923bb85cb1a43756c95833331c65ef63ec040e86aa8ed616a6623b74c36f1aa98138c0212102814c7f config-vanilla.x86