aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-08-02 08:18:55 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-08-02 08:18:55 +0000
commita0e3ae1279815d5ed5ce4c45f681463148219c60 (patch)
treefa47abd8543e6c42eff172135fc297cf23ccd8af
parent16354c44b431a0c9861ad169a78490e6df3f283a (diff)
downloadaports-a0e3ae1279815d5ed5ce4c45f681463148219c60.tar.bz2
aports-a0e3ae1279815d5ed5ce4c45f681463148219c60.tar.xz
main/busybox, scripts/bootstrap: fix bootstrap
busybox now requires ssl on the target host. Fix busybox dependency and adjust bootstrap build order accordingly.
-rw-r--r--main/busybox/APKBUILD4
-rwxr-xr-xscripts/bootstrap.sh4
2 files changed, 4 insertions, 4 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index ea8e17c543..6807faa647 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -8,8 +8,8 @@ pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
arch="all"
license="GPL-2.0"
-makedepends_build="libressl-dev"
-makedepends_host="linux-headers"
+makedepends_build=""
+makedepends_host="linux-headers libressl-dev"
makedepends="$makedepends_build $makedepends_host"
checkdepends="zip"
provides="/bin/sh"
diff --git a/scripts/bootstrap.sh b/scripts/bootstrap.sh
index 1f42985200..f0182e1e26 100755
--- a/scripts/bootstrap.sh
+++ b/scripts/bootstrap.sh
@@ -96,8 +96,8 @@ apk info --quiet --installed --root "$CBUILDROOT" libgcc libstdc++ musl-dev || \
# ordered cross-build
for PKG in fortify-headers linux-headers musl libc-dev pkgconf zlib \
- busybox busybox-initscripts binutils make \
- libressl apk-tools file \
+ libressl busybox busybox-initscripts binutils make \
+ apk-tools file \
gmp mpfr3 mpc1 isl cloog gcc \
openrc alpine-conf alpine-baselayout alpine-keys alpine-base build-base \
attr libcap patch sudo acl fakeroot tar \