aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2018-02-04 09:58:39 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-02-05 18:56:44 +0000
commitc365e9a90933b533c3a92481427e3c54f445a542 (patch)
treeefbcc35dcc91a1b9f5a7589075f07576211ed2db
parentac324f6e0772f432a8bfb18793c501e2e959b5b1 (diff)
downloadaports-c365e9a90933b533c3a92481427e3c54f445a542.tar.bz2
aports-c365e9a90933b533c3a92481427e3c54f445a542.tar.xz
testing/py-netdisco: upgrade to 1.2.4
-rw-r--r--testing/py-netdisco/APKBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/testing/py-netdisco/APKBUILD b/testing/py-netdisco/APKBUILD
index a75d2275c8..86fbdfbf0b 100644
--- a/testing/py-netdisco/APKBUILD
+++ b/testing/py-netdisco/APKBUILD
@@ -1,12 +1,14 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-netdisco
_pkgname=netdisco
-pkgver=1.2.2
+pkgver=1.2.4
pkgrel=0
pkgdesc="Python library to scan local network for services and devices"
url="https://github.com/home-assistant/netdisco/"
arch="noarch"
license="MIT"
+# Tests require netlink support which is no present in AL
+options="!check"
depends="py-zeroconf py-requests py-netifaces"
makedepends="python2-dev py-setuptools python3-dev"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
@@ -15,8 +17,14 @@ builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
}
package() {
@@ -44,4 +52,4 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="c84889c8636761c2b00091d8e2c980d917227f268b32789a23a2f01069a246eef26df2d3cbe56fe0bb34f211f0fd2967b22764e5cef91391fb36a8c3b5371488 netdisco-1.2.2.tar.gz"
+sha512sums="adb19ec9393708c02595029da40f2485dffb5d1215f72231757e4fe062f99b9426f2a0550cfd3b91bea930c5099d0da40bb29e57d0be07292b2e377ea978b400 netdisco-1.2.4.tar.gz"