aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2018-07-30 10:40:09 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-31 11:26:51 +0000
commite572e4ab43a4ddad00ac7f096b0ecafe66b7dba3 (patch)
tree845974126a06e4ff6fb54e2176e5264446447d9b
parente799cd48f2a453326c60eef0f81a71375b8335a7 (diff)
downloadaports-e572e4ab43a4ddad00ac7f096b0ecafe66b7dba3.tar.bz2
aports-e572e4ab43a4ddad00ac7f096b0ecafe66b7dba3.tar.xz
main/py-google-api-python-client: improved dependencies
py3-google-api-python-client should not depend upon python2, python3 is sufficient. Lines 30 and 40 add the python2 dependency to py2-google-api-python-client so specifying python2 on line 10 is not required. Fixes issue #9156
-rw-r--r--main/py-google-api-python-client/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/py-google-api-python-client/APKBUILD b/main/py-google-api-python-client/APKBUILD
index 32fa82315e..5cfa3f2529 100644
--- a/main/py-google-api-python-client/APKBUILD
+++ b/main/py-google-api-python-client/APKBUILD
@@ -2,12 +2,12 @@
pkgname=py-google-api-python-client
_pkgname=google-api-python-client
pkgver=1.7.4
-pkgrel=1
+pkgrel=2
pkgdesc="Google API Client Library for Python"
url="https://github.com/google/google-api-python-client"
arch="noarch"
license="Apache"
-depends="python2 py-httplib2 py-oauth2client py-uritemplate py-six"
+depends="py-httplib2 py-oauth2client py-uritemplate py-six"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"