aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-05-22 17:34:51 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2017-05-22 17:35:27 +0200
commiteef5ee88214fae9422e2069d93724d763ac5d174 (patch)
tree0238edee4199c62dea714e066573cd68f61744ca
parent9f9567bc4746ad714b8991695fb141688c7ec700 (diff)
downloadaports-eef5ee88214fae9422e2069d93724d763ac5d174.tar.bz2
aports-eef5ee88214fae9422e2069d93724d763ac5d174.tar.xz
community/nvme-cli: upgrade to 1.3 and move to community
refs #5082
-rw-r--r--community/nvme-cli/APKBUILD (renamed from testing/nvme-cli/APKBUILD)17
-rw-r--r--testing/nvme-cli/musl-fix.patch29
2 files changed, 6 insertions, 40 deletions
diff --git a/testing/nvme-cli/APKBUILD b/community/nvme-cli/APKBUILD
index a83a3cf671..c687153575 100644
--- a/testing/nvme-cli/APKBUILD
+++ b/community/nvme-cli/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Florian Heigl <florian.heigl@gmail.com>
# Maintainer: Florian Heigl <florian.heigl@gmail.com>
pkgname=nvme-cli
-pkgver=1.1
-pkgrel=1
+pkgver=1.3
+pkgrel=0
pkgdesc="NVM-Express user space tooling for Linux"
arch="all"
url="https://github.com/linux-nvme/nvme-cli"
@@ -11,7 +11,6 @@ depends=""
makedepends="$depends_dev linux-headers coreutils"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp"
source="$pkgname-$pkgver.tar.gz::https://github.com/linux-nvme/nvme-cli/archive/v${pkgver}.tar.gz
- musl-fix.patch
"
builddir="$srcdir"/$pkgname-$pkgver
@@ -32,13 +31,9 @@ bashcomp() {
install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
- mv "$pkgdir"/etc/bash_completion.d/nvme \
- "$subpkgdir"/usr/share/bash-completion/completions/$pkgname || return 1
+ mv "$pkgdir"/usr/share/bash_completion.d/nvme \
+ "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
+ rmdir "$pkgdir"/usr/share/bash_completion.d
}
-md5sums="450b5c381c83df8f117824e7d0fe0076 nvme-cli-1.1.tar.gz
-f8e92a9d93b8cde78b82ad40f89f2c19 musl-fix.patch"
-sha256sums="22883719cbab86d52e8d4755e86ebd70476416e87442385a79b31c981bd60de1 nvme-cli-1.1.tar.gz
-79328b8836c27c661f12fd8a719bf27559c4824c2dd9a10dcf698e1373a007de musl-fix.patch"
-sha512sums="339da4385c5e8659a8f3c2e11afadf437d9cdf02c294674e5cc569cd817174c8ccbd4fc8858ce6f5b8f63ccba68790b2140fc87fdf33b7d394b67999ac4afad0 nvme-cli-1.1.tar.gz
-01cea64b9593b4aac5c13a18538a561b5d538437232dc67f17d955c1661d42cf62671924277449f9611e0fb543cddc7e4ba89e34ff764eb86929201f1e336faa musl-fix.patch"
+sha512sums="0794e72124e73af619a71dd01879d178ad48d30155326e854fb5447e0bb5b879049a7a0a2e3b5301a0de1207034fbbdca07ecf647ff7d4085d56dc793271b576 nvme-cli-1.3.tar.gz"
diff --git a/testing/nvme-cli/musl-fix.patch b/testing/nvme-cli/musl-fix.patch
deleted file mode 100644
index 873233bfc8..0000000000
--- a/testing/nvme-cli/musl-fix.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 329df07e86c27308a3c3fee9054390bc0271e8b8 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Mon, 26 Dec 2016 23:12:58 +0100
-Subject: [PATCH] Include endian.h for byte/host order functions
-
-Fix the following error when building with musl libc:
-
-nvme.h:136:2: error: implicit declaration of function 'le16toh'
-[-Werror=implicit-function-declaration]
- le16toh((__force __u16)(x))
- ^
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- nvme.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/nvme.h b/nvme.h
-index 6623505..5481916 100644
---- a/nvme.h
-+++ b/nvme.h
-@@ -16,6 +16,7 @@
- #define _NVME_H
-
- #include <stdbool.h>
-+#include <endian.h>
- #include "plugin.h"
-
- #define unlikely(x) x