aboutsummaryrefslogtreecommitdiffstats
path: root/community/alpine-make-rootfs/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-04-03 00:46:26 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-04-03 00:46:26 +0200
commit470f33460c9bfebf8f6f70454a9ac7e8ecea815c (patch)
treeabce96916ba562bc9858aa09b307fe1ff4fbcb71 /community/alpine-make-rootfs/APKBUILD
parentf6f93b59dd7fc280cb03b1a3ad2261c4d7318af4 (diff)
downloadaports-470f33460c9bfebf8f6f70454a9ac7e8ecea815c.tar.bz2
aports-470f33460c9bfebf8f6f70454a9ac7e8ecea815c.tar.xz
community/alpine-make-rootfs: move from testing
Diffstat (limited to 'community/alpine-make-rootfs/APKBUILD')
-rw-r--r--community/alpine-make-rootfs/APKBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/community/alpine-make-rootfs/APKBUILD b/community/alpine-make-rootfs/APKBUILD
new file mode 100644
index 0000000000..b0269f1f0b
--- /dev/null
+++ b/community/alpine-make-rootfs/APKBUILD
@@ -0,0 +1,20 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=alpine-make-rootfs
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Make customized Alpine Linux rootfs (base image) for containers"
+url="https://github.com/jirutka/alpine-make-rootfs"
+arch="noarch"
+license="MIT"
+depends="tar"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check" # no suitable tests provided
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+}
+
+sha512sums="26cf0bb2298f578d03e8906a3ee8638465433ecfbbd05606106e33f4b0e0a59cc196c6b98b98fbe8e9ee24a2833ecbabccf50ce3685e6598f4b9b5b8b47b8716 alpine-make-rootfs-0.1.0.tar.gz"