aboutsummaryrefslogtreecommitdiffstats
path: root/community/alpine-make-vm-image/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-04-03 00:46:05 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-04-03 00:46:05 +0200
commitf6f93b59dd7fc280cb03b1a3ad2261c4d7318af4 (patch)
treee57a777bfaf77ca04239bf02bcfa145ce1831367 /community/alpine-make-vm-image/APKBUILD
parente25c15766f5a036de0fc7290cba7b98ef41b46ec (diff)
downloadaports-f6f93b59dd7fc280cb03b1a3ad2261c4d7318af4.tar.bz2
aports-f6f93b59dd7fc280cb03b1a3ad2261c4d7318af4.tar.xz
community/alpine-make-vm-image: move from testing
Diffstat (limited to 'community/alpine-make-vm-image/APKBUILD')
-rw-r--r--community/alpine-make-vm-image/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/alpine-make-vm-image/APKBUILD b/community/alpine-make-vm-image/APKBUILD
new file mode 100644
index 0000000000..5198da9197
--- /dev/null
+++ b/community/alpine-make-vm-image/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=alpine-make-vm-image
+pkgver=0.2.2
+pkgrel=0
+pkgdesc="Make customized Alpine Linux disk image for virtual machines"
+url="https://github.com/alpinelinux/alpine-make-vm-image"
+arch="noarch"
+license="MIT"
+depends="qemu-img"
+source="$pkgname-$pkgver.tar.gz::https://github.com/alpinelinux/$pkgname/archive/v$pkgver.tar.gz
+ only-qemu-img-is-needed.patch
+ no-hardened.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check" # no suitable tests provided
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+}
+
+sha512sums="1169334c4b398da95ff9c115072c09fe43dda06b4cb60a032b87b74023f73c635f52cfddf7f824faff6bef016fc7a81201f66bf22d12cb02438d9d4bc059297c alpine-make-vm-image-0.2.2.tar.gz
+54f1e16ae074dee34443e4b8f82e3eb3c07b97de515508a6b9318ed0c4db572f18d2a073b1d12bd1843a9aff00351a337b93eaed78a1046880f5da064e2230b2 only-qemu-img-is-needed.patch
+6de07784bf7e64799fc1cb8487efc784ac1e8f6a036f8c94d8e126fa9554d6848477f21590f88c251d0ee5b1ca5d94f350cd3e47092708828b3f94ea8a0c3a5f no-hardened.patch"