aboutsummaryrefslogtreecommitdiffstats
path: root/community/binaryen/ignore-type-limits-error.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-06-21 12:35:31 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-06-21 12:36:44 +0200
commitdfe3d6d4ef27a3c3205bcb49e3b88db8684872e5 (patch)
treebde62561f5b638760e6ab2e2608426bbedefe7ce /community/binaryen/ignore-type-limits-error.patch
parenteb21fafa038fecca800661fc3e19713088cc36c8 (diff)
downloadaports-dfe3d6d4ef27a3c3205bcb49e3b88db8684872e5.tar.bz2
aports-dfe3d6d4ef27a3c3205bcb49e3b88db8684872e5.tar.xz
community/binaryen: fix build on aarch64, armhf and ppc64le
This fix is just a temporary workaround! See https://github.com/WebAssembly/binaryen/issues/1059
Diffstat (limited to 'community/binaryen/ignore-type-limits-error.patch')
-rw-r--r--community/binaryen/ignore-type-limits-error.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/community/binaryen/ignore-type-limits-error.patch b/community/binaryen/ignore-type-limits-error.patch
new file mode 100644
index 0000000000..a18a137cfb
--- /dev/null
+++ b/community/binaryen/ignore-type-limits-error.patch
@@ -0,0 +1,11 @@
+This is a temporary workaround for https://github.com/WebAssembly/binaryen/issues/1059.
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -150,6 +150,7 @@
+ endif ()
+ ADD_COMPILE_FLAG("-Wall")
+ ADD_COMPILE_FLAG("-Werror")
++ ADD_COMPILE_FLAG("-Wno-error=type-limits")
+ ADD_COMPILE_FLAG("-Wextra")
+ ADD_COMPILE_FLAG("-Wno-unused-parameter")
+ ADD_COMPILE_FLAG("-fno-omit-frame-pointer")