aboutsummaryrefslogtreecommitdiffstats
path: root/community/cargo
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-20 14:49:18 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-20 14:49:55 +0200
commit3dc0c1d65c029cef8d5252f3d957c64b196c35db (patch)
tree82b46807d18d6a172fc1366560fee8c2b30deb1a /community/cargo
parent6e6ad2ef988a15c87749f3e4832f5018c64bb02d (diff)
downloadaports-3dc0c1d65c029cef8d5252f3d957c64b196c35db.tar.bz2
aports-3dc0c1d65c029cef8d5252f3d957c64b196c35db.tar.xz
community/cargo: add provides=cargo-bootstrap
Prepare for merging the cargo abuild into the rust abuild.
Diffstat (limited to 'community/cargo')
-rw-r--r--community/cargo/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/cargo/APKBUILD b/community/cargo/APKBUILD
index d4c096380e..db49123da2 100644
--- a/community/cargo/APKBUILD
+++ b/community/cargo/APKBUILD
@@ -2,13 +2,17 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=cargo
pkgver=0.25.0
-pkgrel=1
+pkgrel=2
pkgdesc="The Rust package manager"
url="https://crates.io"
arch="x86_64" # limited by rust pkg
license="MIT Apache-2.0"
depends="rust"
makedepends="cmake curl-dev libgit2-dev libssh2-dev libressl-dev python2 zlib-dev"
+# XXX: This is a hack to allow this abuild to depend on itself. Adding "cargo"
+# to makedepends would not work, because abuild implicitly removes $pkgname
+# and $subpackages from the abuild's dependencies.
+provides="cargo-bootstrap=$pkgver-r$pkgrel"
subpackages="$pkgname-doc
$pkgname-bash-completion:bashcomp:noarch
$pkgname-zsh-completion:zshcomp:noarch"