aboutsummaryrefslogtreecommitdiffstats
path: root/community/colordiff
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-05 01:13:47 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-05 01:13:47 +0100
commit945ca243eef686174cd3cd66bf11f55e0271886a (patch)
treef8da01e0cdbd6905ac0c82fc3f269d7f0a24d929 /community/colordiff
parent3865c3679249842506896547815c5b027efe6086 (diff)
downloadaports-945ca243eef686174cd3cd66bf11f55e0271886a.tar.bz2
aports-945ca243eef686174cd3cd66bf11f55e0271886a.tar.xz
community/colordiff: move from testing
Diffstat (limited to 'community/colordiff')
-rw-r--r--community/colordiff/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/colordiff/APKBUILD b/community/colordiff/APKBUILD
new file mode 100644
index 0000000000..03a40e86a8
--- /dev/null
+++ b/community/colordiff/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=colordiff
+pkgver=1.0.18
+pkgrel=0
+pkgdesc="Color terminal highlighter for diff files"
+url="http://www.colordiff.org"
+arch="noarch"
+license="GPL-v2.0-or-later"
+depends="diffutils less perl"
+makedepends="lynx xmlto"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/daveewart/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make doc
+}
+
+check() {
+ cd "$builddir"
+ make -C verify
+}
+
+package() {
+ cd "$builddir"
+ make install \
+ DESTDIR="$pkgdir" \
+ INSTALL_DIR=/usr/bin \
+ MAN_DIR=/usr/share/man/man1
+}
+
+sha512sums="483b29d6dbb53e0c31cfb096808a7b9dde64891180bc29262d02761af91d0d5cf5c0d0972ae678a8ea868b935b02424390166a1141a32320f222635c5184d360 colordiff-1.0.18.tar.gz"