aboutsummaryrefslogtreecommitdiffstats
path: root/community/dcron/pidfile.patch
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-03-20 16:10:29 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2016-03-20 16:10:40 +0100
commite48d7b0222b299462331ff28488119dd15d2dc0a (patch)
tree07272f6d64385ff0eaf0e72c83d1ac5c80ff628f /community/dcron/pidfile.patch
parentdefc1969c09990b29ce46261a86cd5c10db9d950 (diff)
downloadaports-e48d7b0222b299462331ff28488119dd15d2dc0a.tar.bz2
aports-e48d7b0222b299462331ff28488119dd15d2dc0a.tar.xz
community/dcron: moved from testing
Diffstat (limited to 'community/dcron/pidfile.patch')
-rw-r--r--community/dcron/pidfile.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/dcron/pidfile.patch b/community/dcron/pidfile.patch
new file mode 100644
index 0000000000..28a0e27fa1
--- /dev/null
+++ b/community/dcron/pidfile.patch
@@ -0,0 +1,29 @@
+diff -upr dcron-4.5.orig/Makefile dcron-4.5/Makefile
+--- dcron-4.5.orig/Makefile 2016-03-20 00:03:45.043674778 +0100
++++ dcron-4.5/Makefile 2016-03-20 00:04:01.640164147 +0100
+@@ -39,7 +39,7 @@ DEFS = -DVERSION='"$(VERSION)"' \
+ -DTIMESTAMP_FMT='"$(TIMESTAMP_FMT)"'
+
+ # save variables needed for `make install` in config
+-all: $(PROTOS) crond crontab ;
++all: crond crontab ;
+ rm -f config
+ echo "PREFIX = $(PREFIX)" >> config
+ echo "SBINDIR = $(SBINDIR)" >> config
+Only in dcron-4.5: Makefile.orig
+diff -upr dcron-4.5.orig/main.c dcron-4.5/main.c
+--- dcron-4.5.orig/main.c 2016-03-20 00:03:45.043674778 +0100
++++ dcron-4.5/main.c 2016-03-20 00:04:14.933355472 +0100
+@@ -226,6 +226,11 @@ main(int ac, char **av)
+ exit(1);
+ } else if (pid > 0) {
+ /* parent */
++ FILE *fp;
++ if ((fp = fopen("/var/run/dcron.pid", "w")) != NULL) {
++ fprintf(fp, "%d\n", pid);
++ fclose(fp);
++ }
+ exit(0);
+ }
+ /* child continues */
+Only in dcron-4.5: main.c.orig