aboutsummaryrefslogtreecommitdiffstats
path: root/community/dcron
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-03-20 16:10:29 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2016-03-20 16:10:40 +0100
commite48d7b0222b299462331ff28488119dd15d2dc0a (patch)
tree07272f6d64385ff0eaf0e72c83d1ac5c80ff628f /community/dcron
parentdefc1969c09990b29ce46261a86cd5c10db9d950 (diff)
downloadaports-e48d7b0222b299462331ff28488119dd15d2dc0a.tar.bz2
aports-e48d7b0222b299462331ff28488119dd15d2dc0a.tar.xz
community/dcron: moved from testing
Diffstat (limited to 'community/dcron')
-rw-r--r--community/dcron/APKBUILD52
-rw-r--r--community/dcron/dcron.initd12
-rw-r--r--community/dcron/ldflags.patch38
-rw-r--r--community/dcron/pidfile.patch29
4 files changed, 131 insertions, 0 deletions
diff --git a/community/dcron/APKBUILD b/community/dcron/APKBUILD
new file mode 100644
index 0000000000..9ff0d964b3
--- /dev/null
+++ b/community/dcron/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=dcron
+pkgver=4.5
+pkgrel=3
+pkgdesc="dillon's lightweight cron daemon"
+url="http://www.jimpryor.net/linux/dcron.html"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://www.jimpryor.net/linux/releases/${pkgname}-${pkgver}.tar.gz
+ $pkgname.initd
+ pidfile.patch
+ ldflags.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ make PREFIX=/usr \
+ CRONTAB_GROUP=wheel \
+ CRONTABS=/etc/crontabs \
+ CRONSTAMPS=/var/spool/cron/cronstamps \
+ SCRONTABS=/etc/periodic || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm755 "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname || return 1
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
+ install -Dm644 README CHANGELOG \
+ "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+}
+
+md5sums="078833f3281f96944fc30392b1888326 dcron-4.5.tar.gz
+36fb725b46f815dc6692a269ef22dc47 dcron.initd
+c6761a07945edbeecc5726bb0ba92d40 pidfile.patch
+646b16f31abbea4c215512f58f421abc ldflags.patch"
+sha256sums="9e50edb6f5bd8153b16bad05087d985e5153ce45cc01ae77e7f842213fb4a824 dcron-4.5.tar.gz
+dd36b83cd4fa2694119fe046a2432b702ce42c8dc0e87a252cae25a904560acf dcron.initd
+f6c5adf109350eee543549ea63e03d1ac4ca8131d8c8ac1ac7074b222883cfa0 pidfile.patch
+69b907a89d22bcff5ded7ebd749c4e8df87106e290c75110630031e75631ee3a ldflags.patch"
+sha512sums="08521391d16ba5adf80278ec2a734319c26c48841fd94b119c0b27d744c2cfb3562b1a3630135a03d1c43b1668d49262713abb20ff5f7ecd397a2a19a2f6105a dcron-4.5.tar.gz
+0513fc6795988c68f2d552c7754383c6db1f51507686c25cf5205a8491679626118a4bab22c8d5e58017f58cc01ab21af8931fdef806a80f3d27cba2f53831cd dcron.initd
+04fdd3059d6b1df8132944e2eefa932e640db8b4a5ac85dd1ca833adf1d0013ad33f40021624e12a4203b08003d6c79f0a5da4e29b057004fb849f388c7178f2 pidfile.patch
+8a07ccfae80468a555e8f5ea60f88dd444a3aacb6baa6f747a6a02bcdce78baaa8aaf799ae9d2684a518bfff537dc0cdcf0b53bb6fc0017fa52228f1f0a16e49 ldflags.patch"
diff --git a/community/dcron/dcron.initd b/community/dcron/dcron.initd
new file mode 100644
index 0000000000..65b631b9a5
--- /dev/null
+++ b/community/dcron/dcron.initd
@@ -0,0 +1,12 @@
+#!/sbin/openrc-run
+
+name="$SVCNAME"
+command="/usr/sbin/crond"
+command_args="$DCRON_OPTS"
+pidfile="/var/run/$SVCNAME.pid"
+description="Dillon's lightweight cron daemon"
+
+depend() {
+ use logger clock hostname
+ provide cron
+}
diff --git a/community/dcron/ldflags.patch b/community/dcron/ldflags.patch
new file mode 100644
index 0000000000..7fa2d8d9d0
--- /dev/null
+++ b/community/dcron/ldflags.patch
@@ -0,0 +1,38 @@
+From 8a292168e584c50808b80df3577a7d89fa32db26 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 16 May 2011 16:24:20 -0400
+Subject: [PATCH] drop LDFLAGS set, and restore CFLAGS linking
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ Makefile | 5 ++---
+ 1 files changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 1938e05..8309ad6 100644
+--- a/Makefile
++++ b/Makefile
+@@ -32,7 +32,6 @@ TABSRCS = crontab.c chuser.c
+ TABOBJS = crontab.o chuser.o
+ PROTOS = protos.h
+ LIBS =
+-LDFLAGS =
+ DEFS = -DVERSION='"$(VERSION)"' \
+ -DSCRONTABS='"$(SCRONTABS)"' -DCRONTABS='"$(CRONTABS)"' \
+ -DCRONSTAMPS='"$(CRONSTAMPS)"' -DLOG_IDENT='"$(LOG_IDENT)"' \
+@@ -54,10 +53,10 @@ protos.h: $(SRCS) $(TABSRCS)
+ fgrep -h Prototype $(SRCS) $(TABSRCS) > protos.h
+
+ crond: $(OBJS)
+- $(CC) $(LDFLAGS) $^ $(LIBS) -o crond
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ $(LIBS) -o crond
+
+ crontab: $(TABOBJS)
+- $(CC) $(LDFLAGS) $^ -o crontab
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o crontab
+
+ %.o: %.c defs.h $(PROTOS)
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c $(DEFS) $< -o $@
+--
+1.7.5.rc3
+
diff --git a/community/dcron/pidfile.patch b/community/dcron/pidfile.patch
new file mode 100644
index 0000000000..28a0e27fa1
--- /dev/null
+++ b/community/dcron/pidfile.patch
@@ -0,0 +1,29 @@
+diff -upr dcron-4.5.orig/Makefile dcron-4.5/Makefile
+--- dcron-4.5.orig/Makefile 2016-03-20 00:03:45.043674778 +0100
++++ dcron-4.5/Makefile 2016-03-20 00:04:01.640164147 +0100
+@@ -39,7 +39,7 @@ DEFS = -DVERSION='"$(VERSION)"' \
+ -DTIMESTAMP_FMT='"$(TIMESTAMP_FMT)"'
+
+ # save variables needed for `make install` in config
+-all: $(PROTOS) crond crontab ;
++all: crond crontab ;
+ rm -f config
+ echo "PREFIX = $(PREFIX)" >> config
+ echo "SBINDIR = $(SBINDIR)" >> config
+Only in dcron-4.5: Makefile.orig
+diff -upr dcron-4.5.orig/main.c dcron-4.5/main.c
+--- dcron-4.5.orig/main.c 2016-03-20 00:03:45.043674778 +0100
++++ dcron-4.5/main.c 2016-03-20 00:04:14.933355472 +0100
+@@ -226,6 +226,11 @@ main(int ac, char **av)
+ exit(1);
+ } else if (pid > 0) {
+ /* parent */
++ FILE *fp;
++ if ((fp = fopen("/var/run/dcron.pid", "w")) != NULL) {
++ fprintf(fp, "%d\n", pid);
++ fclose(fp);
++ }
+ exit(0);
+ }
+ /* child continues */
+Only in dcron-4.5: main.c.orig