aboutsummaryrefslogtreecommitdiffstats
path: root/community/domoticz
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-05 13:13:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-06 05:19:28 +0000
commit2c00a49e621baf9a311ec4603a9d9e93295f06b3 (patch)
tree0824601372c0d802d5713dd139f4228b82a106b2 /community/domoticz
parenta6863d90192e04d0a7bfa82157c43b2b1f01c69a (diff)
downloadaports-2c00a49e621baf9a311ec4603a9d9e93295f06b3.tar.bz2
aports-2c00a49e621baf9a311ec4603a9d9e93295f06b3.tar.xz
community/domoticz: fix build with boost 1.66
Diffstat (limited to 'community/domoticz')
-rw-r--r--community/domoticz/APKBUILD4
-rw-r--r--community/domoticz/boost-1.66.patch59
2 files changed, 62 insertions, 1 deletions
diff --git a/community/domoticz/APKBUILD b/community/domoticz/APKBUILD
index 47e33181e2..a27f3839e9 100644
--- a/community/domoticz/APKBUILD
+++ b/community/domoticz/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=domoticz
pkgver=3.8153
-pkgrel=1
+pkgrel=2
pkgdesc="Open source Home Automation System"
url="http://www.domoticz.com/"
arch="all !armhf"
@@ -14,6 +14,7 @@ makedepends="cmake libressl-dev zlib-dev curl-dev boost-dev sqlite-dev
"
install="$pkgname.pre-install"
source="domoticz-$pkgver.tar.gz::https://github.com/domoticz/domoticz/archive/$pkgver.tar.gz
+ boost-1.66.patch
domoticz.confd
domoticz.initd
"
@@ -62,5 +63,6 @@ package() {
}
sha512sums="6c4e30b28fa4a5969ddf8a2c275e390394087b036af795921b114c7a734e966b546b33dd353b9aeefce39b30ce502067aadc8616c0fb25b3d97d58aa31922786 domoticz-3.8153.tar.gz
+e839452336c00557e56f999b878e9ff8d32b063241eb45803c0485046691b49371aee41436ccd729c67b3f82166897a248f4493740329984e20b71a245568f16 boost-1.66.patch
724440da335f1e22c8dc181df62dac9ad2bcca98b39bff059de4be5901a93a0a8cb6864d92262092041d796ee7d3933f62cf337316d35a800bbb44f84a1709e0 domoticz.confd
3ddbd3848cce2247a52e4673307a078717d75cb3fea2937d9f2442d94dccd0efc63120f1b0324c7091ae158cd0ec4fd36334af43bb887d45ff4a93e6a96e9bd2 domoticz.initd"
diff --git a/community/domoticz/boost-1.66.patch b/community/domoticz/boost-1.66.patch
new file mode 100644
index 0000000000..766ff02009
--- /dev/null
+++ b/community/domoticz/boost-1.66.patch
@@ -0,0 +1,59 @@
+From 388c7b51716cdb6221ec292cc2456ceca6ee9b02 Mon Sep 17 00:00:00 2001
+From: Rob Peters <ROb@DVBControl.com>
+Date: Wed, 24 Jan 2018 12:03:24 +0100
+Subject: [PATCH] Make compatible with boost 1.66
+
+---
+ msbuild/domoticz.vcxproj | 2 +-
+ webserver/proxyclient.cpp | 2 +-
+ webserver/server.cpp | 4 ++--
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/msbuild/domoticz.vcxproj b/msbuild/domoticz.vcxproj
+index 5c526ed72..cee958414 100755
+--- a/msbuild/domoticz.vcxproj
++++ b/msbuild/domoticz.vcxproj
+@@ -58,7 +58,7 @@
+ <PrecompiledHeader>Use</PrecompiledHeader>
+ <WarningLevel>Level3</WarningLevel>
+ <Optimization>Disabled</Optimization>
+- <PreprocessorDefinitions>WIN32;ENABLE_PYTHON;_DEBUG;PTW32_STATIC_LIB;WITH_OPENZWAVE;OPENZWAVE_USEDLL;WWW_ENABLE_SSL;_CONSOLE;%(PreprocessorDefinitions)</PreprocessorDefinitions>
++ <PreprocessorDefinitions>WIN32;ENABLE_PYTHON;_DEBUG;PTW32_STATIC_LIB;WITH_OPENZWAVE;OPENZWAVE_USEDLL;WWW_ENABLE_SSL;_CONSOLE;BOOST_CONFIG_SUPPRESS_OUTDATED_MESSAGE;%(PreprocessorDefinitions)</PreprocessorDefinitions>
+ <AdditionalIncludeDirectories>./Windows Libraries/Boost;./libusb;../MQTT;..\hardware\openzwave;./Windows Libraries/openssl;./Windows Libraries/Curl;./Windows Libraries/pthread;../hardware/plugins/Include;../tinyxpath;%(AdditionalIncludeDirectories)</AdditionalIncludeDirectories>
+ <RuntimeLibrary>MultiThreadedDebugDLL</RuntimeLibrary>
+ <EnablePREfast>false</EnablePREfast>
+diff --git a/webserver/proxyclient.cpp b/webserver/proxyclient.cpp
+index 6bd6b8771..86baef222 100644
+--- a/webserver/proxyclient.cpp
++++ b/webserver/proxyclient.cpp
+@@ -771,7 +771,7 @@ namespace http {
+ {
+ try {
+ //boost::asio::ssl::context ctx(io_service, boost::asio::ssl::context::tlsv12_client);
+- boost::asio::ssl::context ctx(io_service, boost::asio::ssl::context::sslv23);
++ boost::asio::ssl::context ctx(boost::asio::ssl::context::sslv23);
+ ctx.set_verify_mode(boost::asio::ssl::verify_none);
+
+ proxyclient.reset(new CProxyClient(io_service, ctx, m_pWebEm));
+diff --git a/webserver/server.cpp b/webserver/server.cpp
+index fe001e811..c0eec2166 100644
+--- a/webserver/server.cpp
++++ b/webserver/server.cpp
+@@ -152,7 +152,7 @@ void server::handle_accept(const boost::system::error_code& e) {
+ ssl_server::ssl_server(const ssl_server_settings & ssl_settings, request_handler & user_request_handler) :
+ server_base(ssl_settings, user_request_handler),
+ settings_(ssl_settings),
+- context_(io_service_, ssl_settings.get_ssl_method())
++ context_(ssl_settings.get_ssl_method())
+ {
+ #ifdef DEBUG_WWW
+ _log.Log(LOG_STATUS, "[web:%s] create ssl_server using ssl_server_settings : %s", ssl_settings.listening_port.c_str(), ssl_settings.to_string().c_str());
+@@ -165,7 +165,7 @@ ssl_server::ssl_server(const ssl_server_settings & ssl_settings, request_handler
+ ssl_server::ssl_server(const server_settings & settings, request_handler & user_request_handler) :
+ server_base(settings, user_request_handler),
+ settings_(dynamic_cast<ssl_server_settings const &>(settings)),
+- context_(io_service_, dynamic_cast<ssl_server_settings const &>(settings).get_ssl_method()) {
++ context_(dynamic_cast<ssl_server_settings const &>(settings).get_ssl_method()) {
+ #ifdef DEBUG_WWW
+ _log.Log(LOG_STATUS, "[web:%s] create ssl_server using server_settings : %s", settings.listening_port.c_str(), settings.to_string().c_str());
+ #endif