aboutsummaryrefslogtreecommitdiffstats
path: root/community/entr
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2016-09-14 22:51:14 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-09-15 13:57:45 +0200
commite2b78eade2b2c848cd4ad10ce5bbd97b59a1a09f (patch)
tree32c5077020a057f7fcede81f89518fd6f5f2963c /community/entr
parent03bb8d14be82456d04f3d3b0c4120b9093b1c633 (diff)
downloadaports-e2b78eade2b2c848cd4ad10ce5bbd97b59a1a09f.tar.bz2
aports-e2b78eade2b2c848cd4ad10ce5bbd97b59a1a09f.tar.xz
community/entr: update to 3.6
Diffstat (limited to 'community/entr')
-rw-r--r--community/entr/APKBUILD35
-rw-r--r--community/entr/remove-strlcpy-compat.h.patch14
2 files changed, 10 insertions, 39 deletions
diff --git a/community/entr/APKBUILD b/community/entr/APKBUILD
index f8af64df38..e0c22869b0 100644
--- a/community/entr/APKBUILD
+++ b/community/entr/APKBUILD
@@ -1,43 +1,28 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=entr
-_srcdir=eradman-$pkgname-220131754e1c
-pkgver=3.3
+pkgver=3.6
+_hgrev=c15b0be493fc
pkgrel=0
pkgdesc="Event Notify Test Runner: Run arbitrary commands when files change"
url="http://entrproject.org"
arch="all"
-license="ISC / BSD"
+license="ISC BSD"
subpackages="$pkgname-doc"
-source="http://entrproject.org/code/$pkgname-$pkgver.tar.gz
- remove-strlcpy-compat.h.patch
- "
-
-_builddir="$srcdir"/$_srcdir
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+source="http://entrproject.org/code/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/eradman-$pkgname-$_hgrev"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure || return 1
CFLAGS="-static" make test || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
PREFIX="$pkgdir/usr" make install || return 1
}
-md5sums="769f353934b73e929a0a0fb9fca79c41 entr-3.3.tar.gz
-5ae5aa6f2b8de9747312b32b17c56d0b remove-strlcpy-compat.h.patch"
-sha256sums="701cb7b0a72b6c9ba794ad7cc15b6ebcc2e0c978bb6906c8ae407567a044461f entr-3.3.tar.gz
-2bc42c8c154acf0aaa876b4395c2e0e7b20773e48d50b0c8a15e90ca2e8db472 remove-strlcpy-compat.h.patch"
-sha512sums="aa45bef57fb12d5ddaaebd8de03df33b69a833e4b729ad9fb0844af1c8b7031fc37ca1c81170b20967aa7dbf8854849a7b1f46da6d1d13a49d4d33502269bbca entr-3.3.tar.gz
-9d0f4e06cd5c312788f5ff2efa13f55f78a3491de3ddf64612a6c731072e8514deb1cea48c630194cbda71c58c57e9a6b937172eca58be0b1fb4f0f7a1652e2d remove-strlcpy-compat.h.patch"
+md5sums="072eed7153296a8fae6ebdedefed9fd4 entr-3.6.tar.gz"
+sha256sums="a42746d81c548d7e557d500f93422b8ec9731d719309eb2601b8be69ae0dc8eb entr-3.6.tar.gz"
+sha512sums="a4f607d69e2222ffaeb50c57532fafa88db550d4ab4c633e57e895a8291bb38f6bdd09e92dba2e6fc70e035b2db050ab4c75fb39cd24d00fbde07ef0c03fff8f entr-3.6.tar.gz"
diff --git a/community/entr/remove-strlcpy-compat.h.patch b/community/entr/remove-strlcpy-compat.h.patch
deleted file mode 100644
index ae2d271a1b..0000000000
--- a/community/entr/remove-strlcpy-compat.h.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- eradman-entr-c20e34ec153a/missing/compat.h
-+++ eradman-entr-c20e34ec153a/missing/compat.h.new
-@@ -4,11 +4,6 @@
- #define NOTE_TRUNCATE 0
- #endif
-
--#if defined(_LINUX_PORT)
--#include <sys/types.h>
--size_t strlcpy(char *to, const char *from, int l);
--#endif
--
- #if defined(_MACOS_PORT)
- #include <stdio.h>
- FILE *fmemopen(void *buf, size_t size, const char *mode);