aboutsummaryrefslogtreecommitdiffstats
path: root/community/iptstate
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-25 07:31:56 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-25 07:55:47 +0000
commitcbca79e7d7541625f1082adf89f969cb266b8d93 (patch)
treed4b64f6c0f6801d1080b15618bfc70a0523e7cfc /community/iptstate
parent261908e8db0a78cc3b1cc25e73bedcf2b37cffa7 (diff)
downloadaports-cbca79e7d7541625f1082adf89f969cb266b8d93.tar.bz2
aports-cbca79e7d7541625f1082adf89f969cb266b8d93.tar.xz
community/iptstate: moved from testing, upgraded to 2.2.6
Diffstat (limited to 'community/iptstate')
-rw-r--r--community/iptstate/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/iptstate/APKBUILD b/community/iptstate/APKBUILD
new file mode 100644
index 0000000000..d7fab2be2d
--- /dev/null
+++ b/community/iptstate/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=iptstate
+pkgver=2.2.6
+pkgrel=0
+pkgdesc="top-like interface to netfilter connection-tracking table"
+url="http://www.phildev.net/iptstate/"
+arch="all"
+license="MIT"
+depends=""
+makedepends="ncurses-dev libnetfilter_conntrack-dev libnfnetlink-dev linux-headers"
+install=""
+subpackages="$pkgname-doc"
+source="https://github.com/jaymzh/iptstate/releases/download/v$pkgver/$pkgname-$pkgver.tar.bz2"
+
+builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ install -D -m755 $pkgname "$pkgdir"/usr/sbin/$pkgname
+ install -D -m444 $pkgname.8 "$pkgdir"/usr/share/man/man8/$pkgname.8
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums="ec96c93b43976960d2e2ba3306cd09e6 iptstate-2.2.6.tar.bz2"
+sha256sums="bef8eb67a4533e53079f397b71e91dd34da23f8cbd65cb2d5b67cb907b00c068 iptstate-2.2.6.tar.bz2"
+sha512sums="411b357aced384c52caac17b23f3c6bd631ff34d41b6000b90ff6dfc3cf20e36e46416d3691ac699b06f16d6042a42681b42a5d3594ce287aa6cf3b3b637c999 iptstate-2.2.6.tar.bz2"