aboutsummaryrefslogtreecommitdiffstats
path: root/community/leafpad
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-06-27 10:17:05 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-07-04 11:42:28 +0200
commit2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd (patch)
tree97c60fb3221dfe78cd7ccfda5db6125c81d5f676 /community/leafpad
parent00e8ff605f1c4f6386596f35f2a5287ff9b8bc55 (diff)
downloadaports-2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd.tar.bz2
aports-2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd.tar.xz
testing/[various]: move packages to community
Moves the packages listed below from the testing to the community repository after successfully testing of said packages. asciinema at calcurse cmus compton cpio dvd+rw-tools fortune fvwm geary h2o heirloom-mailx leafpad nedit nmh rover tor torsocks urlview vdesk w3m wbar xcalc xclock xeyes xkill
Diffstat (limited to 'community/leafpad')
-rw-r--r--community/leafpad/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/leafpad/APKBUILD b/community/leafpad/APKBUILD
new file mode 100644
index 0000000000..b1c48a80c8
--- /dev/null
+++ b/community/leafpad/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: August Klein <amatcoder@gmail.com>
+# Maintainer: August Klein <amatcoder@gmail.com>
+pkgname=leafpad
+pkgver=0.8.18.1
+pkgrel=0
+pkgdesc="A simple GTK+ text editor"
+url="http://tarot.freeshell.org/leafpad"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev="gtk+2.0-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-lang"
+source="http://download.savannah.gnu.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr --enable-chooser || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ chmod +x ./install-sh
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="254a72fc67505e3aa52884c729cd7b97 leafpad-0.8.18.1.tar.gz"
+sha256sums="959d22ae07f22803bc66ff40d373a854532a6e4732680bf8a96a3fbcb9f80a2c leafpad-0.8.18.1.tar.gz"
+sha512sums="1caad712967f634f585ab32e406534b5ce2c5621008c1eb5b2b48f17ca0f48cd834ea2ea1c67eda4053fa84e8727ff0e708e99d3b5dad838dcf0701389788257 leafpad-0.8.18.1.tar.gz"