aboutsummaryrefslogtreecommitdiffstats
path: root/community/leafpad
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-14 15:05:03 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-09 15:12:22 +0000
commitee94932fed3a5513e19610ebd864cd9f6022ac12 (patch)
tree88416c8b93af036460c8c3d51083b5874a46fe48 /community/leafpad
parent02ac9e68abac660f3eac60600d60c0f85e0cceaf (diff)
downloadaports-ee94932fed3a5513e19610ebd864cd9f6022ac12.tar.bz2
aports-ee94932fed3a5513e19610ebd864cd9f6022ac12.tar.xz
community/leafpad: modernize abuild
Diffstat (limited to 'community/leafpad')
-rw-r--r--community/leafpad/APKBUILD25
1 files changed, 6 insertions, 19 deletions
diff --git a/community/leafpad/APKBUILD b/community/leafpad/APKBUILD
index b1c48a80c8..53dbf2356f 100644
--- a/community/leafpad/APKBUILD
+++ b/community/leafpad/APKBUILD
@@ -10,33 +10,20 @@ license="GPL2"
depends=""
depends_dev="gtk+2.0-dev"
makedepends="$depends_dev"
-install=""
subpackages="$pkgname-lang"
source="http://download.savannah.gnu.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.gz"
-_builddir="$srcdir"/${pkgname}-${pkgver}
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
+builddir="$srcdir"/${pkgname}-${pkgver}
build() {
- cd "$_builddir"
- ./configure --prefix=/usr --enable-chooser || return 1
- make || return 1
+ cd "$builddir"
+ ./configure --prefix=/usr --enable-chooser
+ make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
chmod +x ./install-sh
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-md5sums="254a72fc67505e3aa52884c729cd7b97 leafpad-0.8.18.1.tar.gz"
-sha256sums="959d22ae07f22803bc66ff40d373a854532a6e4732680bf8a96a3fbcb9f80a2c leafpad-0.8.18.1.tar.gz"
sha512sums="1caad712967f634f585ab32e406534b5ce2c5621008c1eb5b2b48f17ca0f48cd834ea2ea1c67eda4053fa84e8727ff0e708e99d3b5dad838dcf0701389788257 leafpad-0.8.18.1.tar.gz"