aboutsummaryrefslogtreecommitdiffstats
path: root/community/libcue
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-04-06 05:21:43 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-04-06 05:22:42 +0000
commitf0f5681bf672cbdfb03b6efda95ef24165a1d32b (patch)
tree97189abb8fda2b237c861dccd489a1e6dfa49f2c /community/libcue
parent077defc51635798c9c428f05f4d794db201def93 (diff)
downloadaports-f0f5681bf672cbdfb03b6efda95ef24165a1d32b.tar.bz2
aports-f0f5681bf672cbdfb03b6efda95ef24165a1d32b.tar.xz
community/libcue: moved from main
Diffstat (limited to 'community/libcue')
-rw-r--r--community/libcue/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/libcue/APKBUILD b/community/libcue/APKBUILD
new file mode 100644
index 0000000000..a445c63ab5
--- /dev/null
+++ b/community/libcue/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=libcue
+pkgver=2.2.0
+pkgrel=0
+pkgdesc="Library for parsing CUE sheet files"
+url="https://github.com/lipnitsk/libcue"
+license="GPL-2.0"
+arch="all"
+depends=
+makedepends="cmake bison flex"
+install=
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/lipnitsk/libcue/archive/v$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib .
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="638b4fb5eabda750fe7a43200d5f86c45c27ab7b100828ac1f76d155d3e3378a65b4e35e9e2fc17c1f6cf055ac63aff798edaf19ca88ef52966b43b857410018 libcue-2.2.0.tar.gz"