aboutsummaryrefslogtreecommitdiffstats
path: root/community/libqmi
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-02-24 15:11:24 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-02-26 19:40:59 +0000
commit9a1a996ab7341b7a4226825997167ae0feef3119 (patch)
tree6a1998a5a80de020c69b1575ba2ef8753be7446f /community/libqmi
parent3e1b299ff1be8e7ff9dfe0b9e389a61ee2f1b882 (diff)
downloadaports-9a1a996ab7341b7a4226825997167ae0feef3119.tar.bz2
aports-9a1a996ab7341b7a4226825997167ae0feef3119.tar.xz
community/libqmi: update to 1.17.901
includes a compatibility patch to fix canonicalize_file_name() not being part of musl libc.
Diffstat (limited to 'community/libqmi')
-rw-r--r--community/libqmi/APKBUILD12
-rw-r--r--community/libqmi/fix-unknown-fd_set.patch10
-rw-r--r--community/libqmi/musl-compat-canonicalize_file_name.patch26
3 files changed, 30 insertions, 18 deletions
diff --git a/community/libqmi/APKBUILD b/community/libqmi/APKBUILD
index 7dde4c04eb..232c284fd4 100644
--- a/community/libqmi/APKBUILD
+++ b/community/libqmi/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=libqmi
-pkgver=1.17.900
+pkgver=1.17.901
pkgrel=0
pkgdesc="QMI modem protocol helper library"
url="http://www.freedesktop.org/wiki/Software/libqmi"
@@ -10,7 +10,7 @@ license="GPL2"
makedepends="gtk-doc python2 glib-dev libgudev-dev linux-headers"
subpackages="$pkgname-dev $pkgname-doc"
source="https://www.freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz
- fix-unknown-fd_set.patch
+ musl-compat-canonicalize_file_name.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -32,9 +32,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="2589a45756484122b1045cf08adc1dea libqmi-1.17.900.tar.xz
-c5fd4bda7a7c510b1a733e6fdf66c570 fix-unknown-fd_set.patch"
-sha256sums="4a4aeff7fcb56248ed0c82bdf14cec251ca0d332310775bd178408f52d11e7fb libqmi-1.17.900.tar.xz
-9636ee40cc22bfcdc6a6f4702fce105e8c7c4d482f7affac7957cf5b6f7754ed fix-unknown-fd_set.patch"
-sha512sums="a6f8bc1a276e69a8c1fc5f11a5693bdb4746c5c682dde5aaa7f7b1bab14adf5602467c9979c3393aa4e3fa4bbde79a4fcf9cda34c03dbe5c8c34b4d85de67194 libqmi-1.17.900.tar.xz
-10b99ec481fc90fe424bf2393e4ae1764b116465ec65cd01122ff95d7b6ebf811a3a1e5eb6e3fc328f1f8a65da59886c885b483c2ffeee5e4809d34d01e13b64 fix-unknown-fd_set.patch"
+sha512sums="31db491460a43f9f1cbbfe28c2133edbcf51b9762a5c1f81f9c0c8db7878e563269646de15e56eeedcda632016d5250f67cf4395ec8a5085d720fa5ac0ae78c7 libqmi-1.17.901.tar.xz
+57e6e6f142119a9ad5074475f9f18845271d6582ec485422ebe29f00f8a6da49f6770d9b8ff9fb97d1b6367a93766e3ebe4d05b415ad65713a093434fd962d19 musl-compat-canonicalize_file_name.patch"
diff --git a/community/libqmi/fix-unknown-fd_set.patch b/community/libqmi/fix-unknown-fd_set.patch
deleted file mode 100644
index 03e21d4dda..0000000000
--- a/community/libqmi/fix-unknown-fd_set.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- libqmi-1.17.900/utils/swi-update.c
-+++ libqmi-1.17.900/utils/swi-update.c.new
-@@ -40,6 +40,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <sys/stat.h>
-+#include <sys/select.h>
- #include <termios.h>
- #include <unistd.h>
-
diff --git a/community/libqmi/musl-compat-canonicalize_file_name.patch b/community/libqmi/musl-compat-canonicalize_file_name.patch
new file mode 100644
index 0000000000..3ed1baf57e
--- /dev/null
+++ b/community/libqmi/musl-compat-canonicalize_file_name.patch
@@ -0,0 +1,26 @@
+--- libqmi-1.17.901/src/libqmi-glib/qmi-utils.h
++++ libqmi-1.17.901/src/libqmi-glib/qmi-utils.h.new
+@@ -29,6 +29,23 @@
+ #error "Only <libqmi-glib.h> can be included directly."
+ #endif
+
++#ifndef HAVE_CANONICALIZE_FILE_NAME
++#include <limits.h>
++#include <string.h>
++#include <stdlib.h>
++static char * canonicalize_file_name(const char *path)
++{
++ char buf[PATH_MAX] = { };
++
++ snprintf(buf, sizeof(buf) - 1, "%s", path);
++
++ if (!realpath(path, buf))
++ return NULL;
++
++ return strdup(buf);
++}
++#endif
++
+ #include <glib.h>
+
+ G_BEGIN_DECLS