aboutsummaryrefslogtreecommitdiffstats
path: root/community/libwacom
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-03-01 03:12:40 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-03-01 03:12:40 +0000
commit406be0cebe7af94612f6245d085748e0c2149490 (patch)
treef6ea1765ab48276a0723a967249471a9acd190a3 /community/libwacom
parent0928f7eb0baae27df40e03930b73b8c665faf911 (diff)
downloadaports-406be0cebe7af94612f6245d085748e0c2149490.tar.bz2
aports-406be0cebe7af94612f6245d085748e0c2149490.tar.xz
community/libwacom: move from testing
Diffstat (limited to 'community/libwacom')
-rw-r--r--community/libwacom/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/libwacom/APKBUILD b/community/libwacom/APKBUILD
new file mode 100644
index 0000000000..249bd551ef
--- /dev/null
+++ b/community/libwacom/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Ivan Tham <pickfire@riseup.net>
+# Maintainer: Ivan Tham <pickfire@riseup.net>
+pkgname=libwacom
+pkgver=0.24
+pkgrel=1
+pkgdesc="Library to help implement Wacom tablet settings"
+url="http://linuxwacom.sourceforge.net/"
+arch="all"
+license="MIT"
+depends=""
+makedepends="libgudev-dev"
+checkdepends="bash findutils"
+install=""
+subpackages="$pkgname-dev"
+source="https://downloads.sourceforge.net/project/linuxwacom/$pkgname/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -dm755 "$pkgdir"/usr/lib/udev/rules.d/
+ tools/generate-udev-rules
+ > "$pkgdir"/usr/lib/udev/rules.d/65-libwacom.rules
+}
+
+sha512sums="331acb33ab798abf376f70647786c894014d5baa373cc66d53f1e77e77129ba78ec059f32f5cf3659a1fe3e8f9ff6ab3eb6eefd6090fc3c3bab4582ea25a5640 libwacom-0.24.tar.bz2"