aboutsummaryrefslogtreecommitdiffstats
path: root/community/llvm4/fix-CheckAtomic.cmake.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-06 17:22:06 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-14 18:44:44 +0100
commit5264d838ede53a1afd1b238ad278041b6e4203cf (patch)
treecae212e2c200a462ffc0e01fa1a25a840dc3e8b2 /community/llvm4/fix-CheckAtomic.cmake.patch
parent826612567b84723123e7b1e6ea82721f0cf65163 (diff)
downloadaports-5264d838ede53a1afd1b238ad278041b6e4203cf.tar.bz2
aports-5264d838ede53a1afd1b238ad278041b6e4203cf.tar.xz
community/llvm4: move from main
The default (latest) llvm package is now llvm5.
Diffstat (limited to 'community/llvm4/fix-CheckAtomic.cmake.patch')
-rw-r--r--community/llvm4/fix-CheckAtomic.cmake.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/llvm4/fix-CheckAtomic.cmake.patch b/community/llvm4/fix-CheckAtomic.cmake.patch
new file mode 100644
index 0000000000..a5309de6cf
--- /dev/null
+++ b/community/llvm4/fix-CheckAtomic.cmake.patch
@@ -0,0 +1,22 @@
+This cmake file uses command CHECK_LIBRARY_EXISTS that is defined in
+module CheckLibraryExists, but it does not include that module.
+
+This caused build error in lldb, but only on x86 (not x86_64)...
+
+ -- Performing Test HAVE_CXX_ATOMICS64_WITHOUT_LIB - Failed
+ CMake Error at /usr/lib/llvm4/lib/cmake/llvm/CheckAtomic.cmake:66 (check_library_exists):
+ Unknown CMake command "check_library_exists".
+ Call Stack (most recent call first):
+ cmake/modules/LLDBStandalone.cmake:90 (include)
+ CMakeLists.txt:3 (include)
+
+--- a/cmake/modules/CheckAtomic.cmake
++++ b/cmake/modules/CheckAtomic.cmake
+@@ -1,6 +1,7 @@
+ # atomic builtins are required for threading support.
+
+ INCLUDE(CheckCXXSourceCompiles)
++INCLUDE(CheckLibraryExists)
+
+ # Sometimes linking against libatomic is required for atomic ops, if
+ # the platform doesn't support lock-free atomics.