aboutsummaryrefslogtreecommitdiffstats
path: root/community/mpc
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-02-14 09:28:54 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2018-02-14 09:47:34 +0100
commit451ad74e33672be2644cc48323c192ca76428800 (patch)
tree81f4be03138c5ef173b4befca37849f577ead46a /community/mpc
parentfa02ec94000d1cf0cc675e3d834d9249f0fbbf79 (diff)
downloadaports-451ad74e33672be2644cc48323c192ca76428800.tar.bz2
aports-451ad74e33672be2644cc48323c192ca76428800.tar.xz
community/mpc: upgrade to 0.29
Diffstat (limited to 'community/mpc')
-rw-r--r--community/mpc/0001-doc-meson.build-drop-bogus-man-from-manpage-install-.patch29
-rw-r--r--community/mpc/APKBUILD27
2 files changed, 43 insertions, 13 deletions
diff --git a/community/mpc/0001-doc-meson.build-drop-bogus-man-from-manpage-install-.patch b/community/mpc/0001-doc-meson.build-drop-bogus-man-from-manpage-install-.patch
new file mode 100644
index 0000000000..c99cea7804
--- /dev/null
+++ b/community/mpc/0001-doc-meson.build-drop-bogus-man-from-manpage-install-.patch
@@ -0,0 +1,29 @@
+From 2d6e3fe90ae2c24d29305037b452b4cb18bceaa0 Mon Sep 17 00:00:00 2001
+From: Max Kellermann <max@musicpd.org>
+Date: Mon, 12 Feb 2018 21:50:44 +0100
+Subject: [PATCH] doc/meson.build: drop bogus "man" from manpage install path
+
+Closes #12
+---
+ doc/meson.build | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/doc/meson.build b/doc/meson.build
+index fd7e3d6..7793627 100644
+--- a/doc/meson.build
++++ b/doc/meson.build
+@@ -15,9 +15,9 @@ if sphinx.found()
+ 'Manpage documentation',
+ output: 'man',
+ input: ['index.rst', 'conf.py'],
+- command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/doctrees', meson.current_source_dir(), '@OUTPUT@'],
++ command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/doctrees', meson.current_source_dir(), '@OUTPUT@/man1'],
+ build_by_default: true,
+ install: true,
+- install_dir: join_paths(get_option('datadir'), 'man', 'man1'),
++ install_dir: get_option('datadir'),
+ )
+ endif
+--
+2.16.1
+
diff --git a/community/mpc/APKBUILD b/community/mpc/APKBUILD
index 6cd425f042..cda6059aa2 100644
--- a/community/mpc/APKBUILD
+++ b/community/mpc/APKBUILD
@@ -1,33 +1,33 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mpc
-pkgver=0.28
-pkgrel=1
+pkgver=0.29
+pkgrel=0
pkgdesc="Minimalist command line interface to MPD"
url="https://www.musicpd.org/clients/mpc/"
arch="all"
license="GPL-2.0"
-makedepends="libmpdclient-dev"
+makedepends="libmpdclient-dev py-sphinx meson"
subpackages="$pkgname-bash-completion:bashcomp:noarch $pkgname-doc"
-source="http://www.musicpd.org/download/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
-
+source="http://www.musicpd.org/download/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
+ 0001-doc-meson.build-drop-bogus-man-from-manpage-install-.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ meson \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
- make
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C output install
}
bashcomp() {
@@ -36,8 +36,9 @@ bashcomp() {
install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
- mv "$pkgdir"/usr/share/doc/$pkgname/$pkgname-completion.bash \
+ mv "$pkgdir"/usr/share/doc/mpc/contrib/mpc-completion.bash \
"$subpkgdir"/usr/share/bash-completion/completions/$pkgname
}
-sha512sums="1d0c96c3c7cee2eac2d3cf25f09d74b5807b8ea56ff7dfc033b8fa690fd4d42de726a641e4f2552550d8a1c1b2840575aec5c595166ca5ae5776fcc93c8fb7cf mpc-0.28.tar.xz"
+sha512sums="3013b43f3b7d9a1b591c498515440afde1ba16656199f821addbc5018e2e6b0c84c4c7aa9ddbac40a51260d4ba3c281c128a61801f0cdfade5d10e9ead031757 mpc-0.29.tar.xz
+870d97246cb89de68ebcb98ba21efe1f8b9b65bf6bb1353ea8c82c9a024624931fb07104a1e58103054b8dff588b4627077168fc9830a6be50bb86c9bed9117b 0001-doc-meson.build-drop-bogus-man-from-manpage-install-.patch"