aboutsummaryrefslogtreecommitdiffstats
path: root/community/notmuch/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-17 20:30:25 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-17 20:32:56 +0200
commitabea57f861cf8cf0d0fc065a077ffa1b2ca6a66c (patch)
tree6f5db1e4640114352bc27e984a26066b8a938153 /community/notmuch/APKBUILD
parent2c6790a8c5233327fbdd61a5fec71f2aa9727021 (diff)
downloadaports-abea57f861cf8cf0d0fc065a077ffa1b2ca6a66c.tar.bz2
aports-abea57f861cf8cf0d0fc065a077ffa1b2ca6a66c.tar.xz
community/notmuch: enable testsuite partially
Also modernize the APKBUILD
Diffstat (limited to 'community/notmuch/APKBUILD')
-rw-r--r--community/notmuch/APKBUILD46
1 files changed, 37 insertions, 9 deletions
diff --git a/community/notmuch/APKBUILD b/community/notmuch/APKBUILD
index 3ee15c87f3..b527a81ff0 100644
--- a/community/notmuch/APKBUILD
+++ b/community/notmuch/APKBUILD
@@ -2,19 +2,22 @@
# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=notmuch
pkgver=0.24.1
-pkgrel=0
+pkgrel=1
pkgdesc="E-Mail index, search and tagging"
url="https://notmuchmail.org/"
arch="all"
license="GPL3"
makedepends="gzip xapian-core-dev gmime-dev talloc-dev
py-sphinx py-requests bash-completion"
+checkdepends="sed coreutils diffutils bash tar gdb
+ gnupg mdocml grep"
subpackages="
$pkgname-dev
$pkgname-doc
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch"
-source="https://notmuchmail.org/releases/$pkgname-$pkgver.tar.gz"
+source="https://notmuchmail.org/releases/$pkgname-$pkgver.tar.gz
+ fix-tests.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -27,14 +30,38 @@ build() {
--mandir=/usr/share/man \
--localstatedir=/var \
--bashcompletiondir=/usr/share/bash-completion/completions \
- --zshcompletiondir=/usr/share/zsh/site-functions \
- || return 1
- make PREFIX=/usr DESTDIR="$pkgdir" || return 1
+ --zshcompletiondir=/usr/share/zsh/site-functions
+ make PREFIX=/usr DESTDIR="$pkgdir"
}
package() {
make PREFIX=/usr DESTDIR="$pkgdir" \
- -C "$builddir" install || return 1
+ -C "$builddir" install
+}
+
+check() {
+ cd "$builddir"/test
+ make test-binaries
+
+ local test=
+ for test in T*.sh; do
+ name="$(basename "$test")"
+ case "${name%%.*}" in
+ # Requires dtach ↦ doesn't work on the builders
+ *emacs*) continue ;;
+
+ # FIXME xapian fuckup
+ T050-new|T060-count|T150-tagging) continue ;;
+
+ # FIXME gdb fuckup
+ T070-insert) continue ;;
+
+ # FIXME uknown fuckup
+ T170-sexp|T350-crypto|T355-smime) continue ;;
+ esac
+
+ ./${test}
+ done
}
bashcomp() {
@@ -44,7 +71,7 @@ bashcomp() {
mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/
mv "$pkgdir"/usr/share/bash-completion/completions/$pkgname \
- "$subpkgdir"/usr/share/bash-completion/completions/ || return 1
+ "$subpkgdir"/usr/share/bash-completion/completions/
}
zshcomp() {
@@ -54,7 +81,8 @@ zshcomp() {
mkdir -p "$subpkgdir"/usr/share/zsh/site-functions/
mv "$pkgdir"/usr/share/zsh/site-functions/_${pkgname} \
- "$subpkgdir"/usr/share/zsh/site-functions/ || return 1
+ "$subpkgdir"/usr/share/zsh/site-functions/
}
-sha512sums="e2014380de68de3e1a3fd3058a441c6771a92bfffe07c0bd2b374802dd8b2539eddbbb91074738f58f48452a936f2f9427fadca825a165c61a27fe0c3e1fe7fc notmuch-0.24.1.tar.gz"
+sha512sums="e2014380de68de3e1a3fd3058a441c6771a92bfffe07c0bd2b374802dd8b2539eddbbb91074738f58f48452a936f2f9427fadca825a165c61a27fe0c3e1fe7fc notmuch-0.24.1.tar.gz
+586b046d12c73c2f53451f3dfcfe1917aaba5557709ecf41ec8a4a3b5f174b8f1b641141d3059d67c67dad97a760e54285e8a683e3a2f0d17d4c0df6bc342a58 fix-tests.patch"