aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocaml
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-04 18:08:33 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-04 18:09:13 +0200
commit6c142172499e3f933afae642aa85b2e927f5deb2 (patch)
tree7ed92bf1f6968f001cc53c3aa609372b47db5401 /community/ocaml
parentf0b0983956a2b7e9d1c02eb34c33d3c41537bf60 (diff)
downloadaports-6c142172499e3f933afae642aa85b2e927f5deb2.tar.bz2
aports-6c142172499e3f933afae642aa85b2e927f5deb2.tar.xz
community/ocaml: set -e build fix and modernize
Diffstat (limited to 'community/ocaml')
-rw-r--r--community/ocaml/APKBUILD19
1 files changed, 3 insertions, 16 deletions
diff --git a/community/ocaml/APKBUILD b/community/ocaml/APKBUILD
index 5c6badb4ec..ebf7ce4876 100644
--- a/community/ocaml/APKBUILD
+++ b/community/ocaml/APKBUILD
@@ -18,19 +18,9 @@ source="http://caml.inria.fr/pub/distrib/ocaml-${pkgver%.*}/$pkgname-$pkgver.tar
050_all_objinfoldflags.patch
"
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
#strip out -fomit-frame-pointer due to -pg
local _cflags="$CFLAGS"
@@ -51,14 +41,11 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make BINDIR="$pkgdir"/usr/bin LIBDIR="$pkgdir"/usr/lib/ocaml MANDIR="$pkgdir"/usr/share/man install || return 1
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-
- install -Dm644 INSTALL "$pkgdir"/usr/share/doc/$pkgname/INSTALL
install -Dm644 Changes "$pkgdir"/usr/share/doc/$pkgname/Changes
- install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
find "$pkgdir"/usr/lib/ocaml -name \*.ml -delete
}