aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-ipc-run
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-06-16 08:22:40 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-06-16 08:32:52 +0000
commit47b25f3cfeca0639e3adf7b4da08f347f115573b (patch)
treebe703a75cf719d407e4fd01ad5acd9776c35316d /community/perl-ipc-run
parent624caf9cec6811d88ded2bef2e6e4873ec247d23 (diff)
downloadaports-47b25f3cfeca0639e3adf7b4da08f347f115573b.tar.bz2
aports-47b25f3cfeca0639e3adf7b4da08f347f115573b.tar.xz
community/perl-ipc-run: upgrade to 0.96, added check() function
Diffstat (limited to 'community/perl-ipc-run')
-rw-r--r--community/perl-ipc-run/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/community/perl-ipc-run/APKBUILD b/community/perl-ipc-run/APKBUILD
index 1f4bb8ebfc..17b0dcc0f6 100644
--- a/community/perl-ipc-run/APKBUILD
+++ b/community/perl-ipc-run/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-ipc-run
_pkgreal=IPC-Run
-pkgver=0.94
+pkgver=0.96
pkgrel=0
pkgdesc="system() and background procs w/ piping, redirs, ptys (Unix, Win32)"
url="http://search.cpan.org/dist/IPC-Run/"
@@ -15,25 +15,27 @@ depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+check() {
+ cd "$builddir"
+ make test
+}
prepare() {
- cd "$_builddir"
+ cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="c963902894d3796b16624b3b4aea94b4 IPC-Run-0.94.tar.gz"
-sha256sums="2eb336c91a2b7ea61f98e5b2282d91020d39a484f16041e2365ffd30f8a5605b IPC-Run-0.94.tar.gz"
-sha512sums="c42fb5e0a5085698bec3f970ba642c00ad947629bd30c1485ebd28e8e24db4273fa6439e0abeddbc602be66e4ebfcaaa7e8d3982ac8b82c3c6a8a431c170f721 IPC-Run-0.94.tar.gz"
+sha512sums="8a531a2126c15653ab0230813985cc7c83f2c3467c987757fc1f04c3c9952ee0246bcf743dcc4381351c72989f7271ede16962cca24e030404e414ff000c57a8 IPC-Run-0.96.tar.gz"