aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-iptables-parse
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-12 02:15:36 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-12 02:16:13 +0000
commit5adff0b77c5d710bcc7ed4b4c5eb2080a23b2064 (patch)
tree8f78d3eaae7a57736bed0b879036677a3762ae72 /community/perl-iptables-parse
parentcb5921909815c262d070c1ff149bb9790ae311d1 (diff)
downloadaports-5adff0b77c5d710bcc7ed4b4c5eb2080a23b2064.tar.bz2
aports-5adff0b77c5d710bcc7ed4b4c5eb2080a23b2064.tar.xz
community/perl-[i-j]*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - rename _builddir to builddir - add missing default_prepare in prepare()
Diffstat (limited to 'community/perl-iptables-parse')
-rw-r--r--community/perl-iptables-parse/APKBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/community/perl-iptables-parse/APKBUILD b/community/perl-iptables-parse/APKBUILD
index 97aa093abe..81d1ef74b2 100644
--- a/community/perl-iptables-parse/APKBUILD
+++ b/community/perl-iptables-parse/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-iptables-parse
_pkgreal=IPTables-Parse
pkgver=1.6.1
-pkgrel=0
+pkgrel=1
pkgdesc="Perl extension for parsing iptables and ip6tables firewall rulesets"
url="http://search.cpan.org/dist/IPTables-Parse/"
arch="noarch"
@@ -16,26 +16,31 @@ makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/M/MR/MRASH/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="72299f0ab6e10a51837a48d51728a6f7 IPTables-Parse-1.6.1.tar.gz"
-sha256sums="b04a2fe8b021673f2035ac94784bb1c5353a0fd936ab8f093ad23af2b33106e4 IPTables-Parse-1.6.1.tar.gz"
sha512sums="7638665e34f06771519bc8989ad57b6308c5efb39ecb32f3f6f208d0ece1675f499452f4b4b5b2ddd25109abecbdb5015e4441431defa8688f33f9eb2ad921eb IPTables-Parse-1.6.1.tar.gz"