aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-regexp-common-net-cidr/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-27 16:53:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-16 20:36:23 +0000
commitd994de25946f8207e3715c367bd52269ec08a19b (patch)
tree0ad3fdad20f970a33db4f169256244eff705466c /community/perl-regexp-common-net-cidr/APKBUILD
parent6b4742b629bd7b2971c69a5887bce5077d469706 (diff)
downloadaports-d994de25946f8207e3715c367bd52269ec08a19b.tar.bz2
aports-d994de25946f8207e3715c367bd52269ec08a19b.tar.xz
community/perl-regexp-common-net-cidr: move from main
It is required only by rt4 package and it is part of community.
Diffstat (limited to 'community/perl-regexp-common-net-cidr/APKBUILD')
-rw-r--r--community/perl-regexp-common-net-cidr/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/perl-regexp-common-net-cidr/APKBUILD b/community/perl-regexp-common-net-cidr/APKBUILD
new file mode 100644
index 0000000000..9ddd359d10
--- /dev/null
+++ b/community/perl-regexp-common-net-cidr/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-regexp-common-net-cidr
+pkgver=0.03
+pkgrel=0
+pkgdesc="Regexp::Common::net::CIDR perl module"
+url="http://search.cpan.org/dist/Regexp-Common-net-CIDR/"
+arch="noarch"
+license="GPL-2.0 or Artistic"
+depends="perl perl-regexp-common"
+makedepends="perl-dev perl-module-install"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/B/BP/BPS/Regexp-Common-net-CIDR-$pkgver.tar.gz"
+
+builddir="$srcdir/Regexp-Common-net-CIDR-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="0ca3d188ea4197af2981c2910e5f5a2d412d760251ee7ad9d688aa6e60f4dfdbf5583d599b1af8698ed7c740c252f0e8bda38de254f03a699122de1c1f598f20 Regexp-Common-net-CIDR-0.03.tar.gz"