aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-yaml
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-03-11 16:42:12 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-03-16 19:09:14 +0200
commitedc429181396519efc2dfd637b3f5d0a501a172d (patch)
tree1bce9fcaaf13e619c9a905588102fe39b1ad031c /community/php7-yaml
parent71e61b8dc3bef4a3a0bb18adb66bd646dd332d36 (diff)
downloadaports-edc429181396519efc2dfd637b3f5d0a501a172d.tar.bz2
aports-edc429181396519efc2dfd637b3f5d0a501a172d.tar.xz
testing/php7-yaml: move to community
Diffstat (limited to 'community/php7-yaml')
-rwxr-xr-xcommunity/php7-yaml/10-detect.patch11
-rw-r--r--community/php7-yaml/APKBUILD42
2 files changed, 53 insertions, 0 deletions
diff --git a/community/php7-yaml/10-detect.patch b/community/php7-yaml/10-detect.patch
new file mode 100755
index 0000000000..ee0f01746e
--- /dev/null
+++ b/community/php7-yaml/10-detect.patch
@@ -0,0 +1,11 @@
+--- a/detect.c 2017-07-29 17:56:18.000000000 -0400
++++ b/detect.c 2017-10-30 21:15:09.000000000 -0400
+@@ -568,7 +568,7 @@ finish:
+ break;
+
+ default:
+- *dval = atof(buf);
++ *dval = zend_strtod(buf, (const char **) NULL);
+ break;
+ }
+ }
diff --git a/community/php7-yaml/APKBUILD b/community/php7-yaml/APKBUILD
new file mode 100644
index 0000000000..43d4ec00e6
--- /dev/null
+++ b/community/php7-yaml/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Renoir Boulanger <hello@renoirboulanger.com>
+pkgname=php7-yaml
+_pkgreal=yaml
+pkgver=2.0.2
+pkgrel=0
+pkgdesc="YAML syntax bindings for PHP"
+url="http://bd808.com/pecl-file_formats-yaml/"
+arch="all"
+license="MIT"
+makedepends="php7-dev autoconf yaml-dev"
+depends="php7-common"
+builddir="$srcdir"/$_pkgreal-$pkgver/
+
+# Set source file explicitly, otherwise extracted archive directory breaks the build.
+source="$pkgname-$pkgver.tgz::http://pecl.php.net/get/$_pkgreal-$pkgver.tgz
+ 10-detect.patch"
+
+build() {
+ cd "$builddir"
+ phpize7
+ ./configure \
+ --prefix=/usr \
+ --with-php-config=php-config7
+ make
+}
+
+# Thanks to @TBK for https://github.com/php/pecl-file_formats-yaml/pull/29
+# added here as 10-detect.patch
+check() {
+ cd "$builddir"
+ NO_INTERACTION=1 REPORT_EXIT_STATUS=1 make test
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir" install
+ install -d $pkgdir/etc/php7/conf.d
+ echo "extension=$_pkgreal.so" > $pkgdir/etc/php7/conf.d/70_$_pkgreal.ini
+}
+
+sha512sums="b3dd2098826cd7cdcfd1e5d97b9015de66812dc90e506e74a4a50a56afed5f9de0449465bb807a36a13170f479897cc62a9b108653aa7eb81895abd5966bde1a php7-yaml-2.0.2.tgz
+3c291ef43ecf43c79d8e02821a6168362404b130f75e154c710fea167c10c71e0f4ffa5be8ca41c0533362d0d3a4d6a140d226f76b84e187788302adba942b4e 10-detect.patch"