aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-django-appconf
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-11 01:47:49 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-11 01:47:49 +0000
commit16e7e0d6f0a651781038d316f885c63c6298388f (patch)
tree273a387835949164258c5fa7942799e2907e4e0c /community/py-django-appconf
parentf6eca43648bcd5f2f5b0cfdaf1195b38e35a52dc (diff)
downloadaports-16e7e0d6f0a651781038d316f885c63c6298388f.tar.bz2
aports-16e7e0d6f0a651781038d316f885c63c6298388f.tar.xz
community/py-django-appconf: modernize APKBUILD
Diffstat (limited to 'community/py-django-appconf')
-rw-r--r--community/py-django-appconf/APKBUILD29
1 files changed, 11 insertions, 18 deletions
diff --git a/community/py-django-appconf/APKBUILD b/community/py-django-appconf/APKBUILD
index aeabcc44ef..c2eb3d7f12 100644
--- a/community/py-django-appconf/APKBUILD
+++ b/community/py-django-appconf/APKBUILD
@@ -1,34 +1,27 @@
# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
# Maintainer: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
pkgname=py-django-appconf
+_pkgname=django-appconf
pkgver=1.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="Packaged application configuation helper for Django"
-url=http://django-appconf.readthedocs.org/
-arch=noarch
-license=BSD
+url="http://django-appconf.readthedocs.org/"
+arch="noarch"
+license="BSD"
depends="py-django py-six"
-makedepends=py-setuptools
-source="https://files.pythonhosted.org/packages/source/d/django-appconf/django-appconf-$pkgver.tar.gz"
+makedepends="py-setuptools"
+options="!check" # No test suite available
+source="https://files.pythonhosted.org/packages/source/d/$_pkgname/$_pkgname-$pkgver.tar.gz"
-_builddir=$srcdir/django-appconf-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py build
}
package() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py install --root "$pkgdir"
}