aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-tempita
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-12-27 07:30:40 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-12-27 07:33:24 +0000
commit8515ffc8b17311230eac82420982b9d84676d63c (patch)
treea3ec40a455d92143519836bd359056e40392d3e7 /community/py-tempita
parent6876ddb98029453002ca3c7f2151dae4136daa08 (diff)
downloadaports-8515ffc8b17311230eac82420982b9d84676d63c.tar.bz2
aports-8515ffc8b17311230eac82420982b9d84676d63c.tar.xz
community/py-tempita: force rebuild for s390x, modernize APKBUILD
Diffstat (limited to 'community/py-tempita')
-rw-r--r--community/py-tempita/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/community/py-tempita/APKBUILD b/community/py-tempita/APKBUILD
index 4a51e2a3f7..45cb2dce52 100644
--- a/community/py-tempita/APKBUILD
+++ b/community/py-tempita/APKBUILD
@@ -3,30 +3,31 @@
pkgname=py-tempita
_pkgname=Tempita
pkgver=0.5.2
-pkgrel=3
+pkgrel=4
pkgdesc="A small templating language"
url="https://pypi.python.org/pypi/Tempita"
arch="noarch"
license="MIT"
makedepends="python2-dev py-setuptools python3-dev"
subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+options="!check" #no testsuite
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
local pyver; for pyver in 2 3; do
- cp -r "$builddir" "$builddir-$pyver" || return 1
+ cp -r "$builddir" "$builddir-$pyver"
done
}
build() {
cd "$builddir-2"
- python2 setup.py build || return 1
+ python2 setup.py build
cd "$builddir-3"
- 2to3 -w . || return 1
+ 2to3 -w .
python3 setup.py build
}