aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aiohttp-gns3
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2018-04-30 21:52:04 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2018-04-30 22:03:30 +0000
commit8620b15df4554a00d09581ad40a52297cd8869f7 (patch)
treebb1c87fc1721fca0f1f62b2ec2f055473f5f5609 /community/py3-aiohttp-gns3
parent5fa2ef24bfd313b2f1554df28a6d816f9f223291 (diff)
downloadaports-8620b15df4554a00d09581ad40a52297cd8869f7.tar.bz2
aports-8620b15df4554a00d09581ad40a52297cd8869f7.tar.xz
community/py3-aiohttp-gns3: new aport
This has been introduced due to a long required compatibility for GNS3. In alpine we are upgrading to the latest version (which often breaks ABI), while GNS3 sticks to older versions. This new aport introduce a layer of compatibility, following what also Archlinux does. It is pushed in community directly in order to be a dependency of GNS3, though has been tested.
Diffstat (limited to 'community/py3-aiohttp-gns3')
-rw-r--r--community/py3-aiohttp-gns3/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/py3-aiohttp-gns3/APKBUILD b/community/py3-aiohttp-gns3/APKBUILD
new file mode 100644
index 0000000000..dc3180c176
--- /dev/null
+++ b/community/py3-aiohttp-gns3/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-aiohttp-gns3
+_pkgname=aiohttp
+pkgver=2.3.10
+pkgrel=0
+pkgdesc="HTTP client/server for asyncio - GNS3 compatible version"
+url="https://pypi.python.org/pypi/aiohttp"
+arch="all"
+license="Apache-2.0"
+depends="python3 py3-async-timeout py3-chardet py3-multidict py3-yarl
+ py3-idna-ssl py3-attrs"
+makedepends="python3-dev py3-setuptools cython-dev"
+conflicts="py3-aiohttp"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --root="$pkgdir" --optimize=1
+}
+
+sha512sums="e4ea725bbd3d7d749f2ec21eea1ff9f5c836fbeaa17ad72f77e378c69b008448e57503175bee6adff86110f65edc915cb6368df3011d1d9d61cf47718b086be0 py3-aiohttp-gns3-2.3.10.tar.gz"