aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-rspec-core
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-25 23:50:25 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-25 23:50:25 +0100
commit3297d634f4371b930eba14293bc829b9c4a5150e (patch)
tree2198f7bd88fa2d064f4a92746f7f46fdd065fb03 /community/ruby-rspec-core
parent94f91d25906569a622b1bdbd61766449230daa27 (diff)
downloadaports-3297d634f4371b930eba14293bc829b9c4a5150e.tar.bz2
aports-3297d634f4371b930eba14293bc829b9c4a5150e.tar.xz
community/ruby-rspec*: move from testing
Diffstat (limited to 'community/ruby-rspec-core')
-rw-r--r--community/ruby-rspec-core/APKBUILD41
-rw-r--r--community/ruby-rspec-core/gemspec.patch16
2 files changed, 57 insertions, 0 deletions
diff --git a/community/ruby-rspec-core/APKBUILD b/community/ruby-rspec-core/APKBUILD
new file mode 100644
index 0000000000..c7539aab9f
--- /dev/null
+++ b/community/ruby-rspec-core/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ruby-rspec-core
+_gemname=${pkgname#ruby-}
+pkgver=3.7.0
+pkgrel=0
+pkgdesc="RSpec runner and formatters"
+url="https://relishapp.com/rspec/rspec-core/"
+arch="noarch"
+license="MIT"
+depends="ruby ruby-rspec-support>=${pkgver%.*}.0"
+options="!check" # rspec's tests are written in rspec
+source="$pkgname-$pkgver.tar.gz::https://github.com/rspec/$_gemname/archive/v$pkgver.tar.gz
+ gemspec.patch"
+builddir="$srcdir/$_gemname-$pkgver"
+
+build() {
+ cd "$builddir"
+ gem build $_gemname.gemspec
+}
+
+package() {
+ local gemdir="$pkgdir/$(ruby -rubygems -e 'puts Gem.default_dir')"
+
+ cd "$builddir"
+ gem install --local \
+ --install-dir "$gemdir" \
+ --bindir "$pkgdir/usr/bin" \
+ --ignore-dependencies \
+ --no-document \
+ --verbose \
+ $_gemname
+
+ # Clean-up...
+ rm -r "$gemdir"/cache \
+ "$gemdir"/build_info \
+ "$gemdir"/doc
+}
+
+sha512sums="071bd2a5c905d4ce621f2d7255b882a9d34cf42001cb2995fdb05a91387805929198c32e53cf4c2df2a43d179d2c49337214066be87eb50ab044b5f70aba8c54 ruby-rspec-core-3.7.0.tar.gz
+e0cbcfddcc4c73d9b9673907e3b1a785b399c0b3b213761e9dbca9fadc55d50a88389eaf561f5603bd674eb94ce9f2ecf829d884eaa77df8ef1b565c0c7f25f2 gemspec.patch"
diff --git a/community/ruby-rspec-core/gemspec.patch b/community/ruby-rspec-core/gemspec.patch
new file mode 100644
index 0000000000..0a6cad0d0e
--- /dev/null
+++ b/community/ruby-rspec-core/gemspec.patch
@@ -0,0 +1,16 @@
+--- a/rspec-core.gemspec
++++ b/rspec-core.gemspec
+@@ -13,11 +13,10 @@
+ s.summary = "rspec-core-#{RSpec::Core::Version::STRING}"
+ s.description = "BDD for Ruby. RSpec runner and example groups."
+
+- s.files = `git ls-files -- lib/*`.split("\n")
+- s.files += %w[README.md LICENSE.md Changelog.md .yardopts .document]
++ s.files = Dir["lib/**/*"]
+ s.test_files = []
+ s.bindir = 'exe'
+- s.executables = `git ls-files -- exe/*`.split("\n").map{ |f| File.basename(f) }
++ s.executables = Dir["exe/*"].map{ |f| File.basename(f) }
+ s.rdoc_options = ["--charset=UTF-8"]
+ s.require_path = "lib"
+