aboutsummaryrefslogtreecommitdiffstats
path: root/community/sl
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-09 00:40:57 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-09 00:41:14 +0200
commite46b20de06a3db083a465da855b3c405435a9e97 (patch)
treec4d0001f79bf17f40e9358c049047a7f0a2ad22f /community/sl
parent179edbc5bc20281c5682af6715c2f9e916db40bc (diff)
downloadaports-e46b20de06a3db083a465da855b3c405435a9e97.tar.bz2
aports-e46b20de06a3db083a465da855b3c405435a9e97.tar.xz
community/sl: move from testing
Diffstat (limited to 'community/sl')
-rw-r--r--community/sl/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/sl/APKBUILD b/community/sl/APKBUILD
new file mode 100644
index 0000000000..9bcc47d3c4
--- /dev/null
+++ b/community/sl/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Andrew Hills <ahills@ednos.net>
+# Maintainer: Andrew Hills <ahills@ednos.net>
+pkgname=sl
+pkgver=5.02
+pkgrel=0
+pkgdesc="Cure your bad habit of mistyping"
+url="https://github.com/mtoyoda/sl"
+arch="all"
+license="MIT"
+makedepends="ncurses-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mtoyoda/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ install -Dm 755 sl "$pkgdir"/usr/bin/sl
+}
+
+sha512sums="a4d18bc79d7e0eca7748b10226a6b2a85a7a01d636e4e9215bf524a7849bc5cb250034326e5a69f7423d79e40b92182fddc0e56e25df616edae06369c782cb26 sl-5.02.tar.gz"