aboutsummaryrefslogtreecommitdiffstats
path: root/community/webkitgtk
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-03-23 01:41:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-03-23 14:35:05 +0000
commit35039ed28c5a58b040a8fc7ab24d39fa2d933c88 (patch)
tree6b3031ec8812ee224c9565f744caf925b0141a06 /community/webkitgtk
parent1adeeda39fe6b077deba6f72918beb67fb066624 (diff)
downloadaports-35039ed28c5a58b040a8fc7ab24d39fa2d933c88.tar.bz2
aports-35039ed28c5a58b040a8fc7ab24d39fa2d933c88.tar.xz
community/webkitgtk: Disable JIT for ppc64le
webkitgt miss code to implement JIT on ppc64le, as on aarch64. Disabling it for ppc64le also.
Diffstat (limited to 'community/webkitgtk')
-rw-r--r--community/webkitgtk/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/webkitgtk/APKBUILD b/community/webkitgtk/APKBUILD
index ce6b8ce5ef..bc83c69562 100644
--- a/community/webkitgtk/APKBUILD
+++ b/community/webkitgtk/APKBUILD
@@ -73,8 +73,8 @@ prepare() {
_build() {
local _ver=$1
- # disable jit on aarch64
- if [ "$CARCH" = "aarch64" ]; then
+ # disable jit on aarch64 and ppc64le
+ if [ "$CARCH" = "aarch64" ] || [ "CARCH" = "ppc64le" ]; then
local _conf="--disable-jit"
export CXXFLAGS="$CXXFLAGS -DENABLE_YARR_JIT=0"
fi