aboutsummaryrefslogtreecommitdiffstats
path: root/community/ykpers/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-04-29 00:16:56 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-04-29 00:16:56 +0200
commitfe4830628ddeb9b2a9a08d162fbfcf402b23ba2b (patch)
treeeb35ab9e52f29c31b68546c88b7a248f9bf27421 /community/ykpers/APKBUILD
parenta6c38746492018053059742ec37860eab33a515e (diff)
downloadaports-fe4830628ddeb9b2a9a08d162fbfcf402b23ba2b.tar.bz2
aports-fe4830628ddeb9b2a9a08d162fbfcf402b23ba2b.tar.xz
community/ykpers: move from testing
Diffstat (limited to 'community/ykpers/APKBUILD')
-rw-r--r--community/ykpers/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/ykpers/APKBUILD b/community/ykpers/APKBUILD
new file mode 100644
index 0000000000..8805c1c36a
--- /dev/null
+++ b/community/ykpers/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ykpers
+pkgver=1.18.1
+pkgrel=0
+pkgdesc="YubiKey Personalization library and tool"
+url="https://developers.yubico.com/yubikey-personalization/"
+arch="all"
+license="BSD-2-Clause"
+makedepends="libusb-dev yubico-c-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://developers.yubico.com/yubikey-personalization/Releases/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --with-udevrulesdir=/usr/lib/udev/rules.d \
+ --with-backend=libusb-1.0
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check CFLAGS="$CFLAGS -D__GLIBC__"
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="8bed7b3089ac64f8be19717e29a237d40ed17eb5d119630405efd1e269d1b967394c45a349d3290056504a71bf30e2f4e56a0e71d0cd611bd3152080173b652c ykpers-1.18.1.tar.gz"