aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-03-27 19:48:07 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-03-27 19:48:07 +0000
commit51357e77883c376fe1ff7f1a2c2cc5dc472a0f00 (patch)
tree468f5a11e4be145b177f64139fbd2171a852182d /community
parent13d77c53f103215714c5b1a6f775b27b7f1c409d (diff)
downloadaports-51357e77883c376fe1ff7f1a2c2cc5dc472a0f00.tar.bz2
aports-51357e77883c376fe1ff7f1a2c2cc5dc472a0f00.tar.xz
community/{bitcoin,entr,firejail}: add cd $builddir to check()
Diffstat (limited to 'community')
-rw-r--r--community/bitcoin/APKBUILD1
-rw-r--r--community/entr/APKBUILD1
-rw-r--r--community/firejail/APKBUILD1
3 files changed, 3 insertions, 0 deletions
diff --git a/community/bitcoin/APKBUILD b/community/bitcoin/APKBUILD
index 8d5ba4c2cc..86870a6cc0 100644
--- a/community/bitcoin/APKBUILD
+++ b/community/bitcoin/APKBUILD
@@ -85,6 +85,7 @@ dev() {
}
check() {
+ cd "$builddir"
make check || return 1
}
diff --git a/community/entr/APKBUILD b/community/entr/APKBUILD
index 4482c87b95..880ebcfab6 100644
--- a/community/entr/APKBUILD
+++ b/community/entr/APKBUILD
@@ -35,6 +35,7 @@ package() {
}
check() {
+ cd "$builddir"
make regress || return 1
}
diff --git a/community/firejail/APKBUILD b/community/firejail/APKBUILD
index 40768f0e59..4c56739419 100644
--- a/community/firejail/APKBUILD
+++ b/community/firejail/APKBUILD
@@ -47,6 +47,7 @@ bashcomp() {
}
check() {
+ cd "$builddir"
make test || return 1
}