aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-08-30 00:02:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-08-30 00:14:01 +0000
commit591c7b7c9c9e814f7428e6581fb124e173e0bae2 (patch)
tree98ba880d11eb18e947fb340351297f4808ba583f /community
parent16dd4f3b7a4c58ce8c3d63d0347525da62ed29b2 (diff)
downloadaports-591c7b7c9c9e814f7428e6581fb124e173e0bae2.tar.bz2
aports-591c7b7c9c9e814f7428e6581fb124e173e0bae2.tar.xz
community/chromium: install the missing icudtl.dat
also add patch that should fix the error: Received signal 4 ILL_ILLOPN 0927de0d1ae4
Diffstat (limited to 'community')
-rw-r--r--community/chromium/APKBUILD10
-rw-r--r--community/chromium/unset-madv_free.patch16
2 files changed, 24 insertions, 2 deletions
diff --git a/community/chromium/APKBUILD b/community/chromium/APKBUILD
index e472248c05..febdebf23c 100644
--- a/community/chromium/APKBUILD
+++ b/community/chromium/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=chromium
pkgver=52.0.2743.116
-pkgrel=0
+pkgrel=1
pkgdesc="chromium web browser"
url="http://www.chromium.org/"
arch="x86_64"
@@ -35,6 +35,7 @@ source="https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
no-getcontext.patch
musl-sandbox.patch
fix-png-decoder-build.patch
+ unset-madv_free.patch
chromium-system-jinja-r7.patch
chromium-widevine.patch
@@ -73,7 +74,6 @@ prepare() {
build() {
cd "$builddir"
-
# currently does not build with system vpx 1.4
# remoting/codec/video_encoder_vpx.cc:308:10: error:
# 'vpx_codec_control_VP9E_GET_ACTIVEMAP' was not declared in this scope
@@ -174,6 +174,9 @@ package() {
install -Dm4755 "$builddir"/out/Release/chrome_sandbox \
"$pkgdir"/usr/lib/$pkgname/chrome-sandbox || return 1
+ install -m644 "$builddir"/out/Release/icudtl.dat \
+ "$pkgdir"/usr/lib/$pkgname/icudtl.dat || return 1
+
for pak in out/Release/*.pak; do
install -Dm644 $pak \
"$pkgdir"/usr/lib/$pkgname/${pak##*/} || return 1
@@ -234,6 +237,7 @@ f99a4572c0be2c2123acc2478905e01f resolver.patch
2c8de771a7c0e5e0e9fc68fa978785f7 no-getcontext.patch
c805e026abc748d9925fab8250760bcc musl-sandbox.patch
e9add89e4b83b2a907f7f9bf7fc70836 fix-png-decoder-build.patch
+183bf3b136f99a0f60f8e171ddd147e8 unset-madv_free.patch
97b1578585ab600ed9adef4f341ccd80 chromium-system-jinja-r7.patch
de717d6430532f34fe161035dfdafcdf chromium-widevine.patch
5f1bca53835b6380b5949c96860f6894 musl-hacks.patch"
@@ -249,6 +253,7 @@ a620b4492cb28e4b0d571ba3b79ec7635506f297824d390167ec7391f23eb27e musl-fixes.pat
ea79f9a46116c8b56bbc69d226abd9252e4ae4d946ca695203f2298279cc2211 no-getcontext.patch
3d0303f9ea04b2c24e16068ea2d423fce0e37ebb2b89dde342f9e8f9d0b149b4 musl-sandbox.patch
1c3d7fb85c09f289efb971285f50ef7ecfbc2c0bf0d063da45ce2edb1c69e69a fix-png-decoder-build.patch
+178fbdd552b21b7675425067b1c6ee84f6a24ec275bb40a0769d71072adfe482 unset-madv_free.patch
872f5a38d8263b14308bb117828496a4093d0e6ad755d39d2c5e6857314fe071 chromium-system-jinja-r7.patch
1d1ead77250475228524770e57c17282aff9098c5efc3d7719b0df76229b8874 chromium-widevine.patch
10a4d81e1d8f70e4993ba0b7e1b9069f18c28190e6660e0f67bf24d598aa7c66 musl-hacks.patch"
@@ -264,6 +269,7 @@ d60407a8faadfd2a8294570163b4d1b1112c8a70a6f8e778fc3aff25d20613a2e26c66cd87e69c54
42d9a6ebea2d95cdc169b921cc1a1b846cf500997059fd3084de09e21f00b63b76e60c6124f4af247d402ff5ca3f4bf8867a6f2c78198c05b4273ca01fb29241 no-getcontext.patch
ce8276bb35a8d72cf58868a6331e85286b350a1aad694525ebf637499819219dd4d87ab67dd3b938830a6bd3e7172fc9bcd9c8971820d0ed95c0d141867a24fe musl-sandbox.patch
87bd7bbe2d16e6c3ad24310d6bfd5170c878f206f5bd132348f6afbad3447f44e015a9f655cce51d221d365f28cc6eec3bfc333fa4afc4bef8c9f3fcb7700fff fix-png-decoder-build.patch
+a86f262d6fde8497ba448052fa8777867633eff7eb71d91e56e005e2c00951a9f447d636e1bc86b682979b6746d1355963df0a6aaf4bb7ae9577226457493e09 unset-madv_free.patch
10bcc6a467b6766d13b5e41e7b7dcdbd62de7c04daad16c83037e88043032a0c118627029f91ef8a2a57faaaebc8b6f4ee16e8d1fecb5921d0d49efd60a27863 chromium-system-jinja-r7.patch
4a11b46afa8ce84bd23a8c506301b5848ee4291a764f3aed282b8a98706ece16cf9346dec6cc71b1e17812b15f43a5cbc7bc6d38ed4dcc88c12d6fcb03bd9295 chromium-widevine.patch
4043dd7a64dcb9b73e15786b407934dd1b171df8b628ab1b18718fd93f9758c76eb25d1bdf1e1a22901544185088b8f817d3e2a58154c54949704dc8cc87b84d musl-hacks.patch"
diff --git a/community/chromium/unset-madv_free.patch b/community/chromium/unset-madv_free.patch
new file mode 100644
index 0000000000..80e62e854c
--- /dev/null
+++ b/community/chromium/unset-madv_free.patch
@@ -0,0 +1,16 @@
+https://bugzilla.redhat.com/show_bug.cgi?id=1361157
+
+--- a/third_party/WebKit/Source/wtf/allocator/PageAllocator.cpp
++++ b/third_party/WebKit/Source/wtf/allocator/PageAllocator.cpp
+@@ -41,6 +41,11 @@
+ #include <errno.h>
+ #include <sys/mman.h>
+
++#if OS(LINUX) && defined(MADV_FREE)
++// Added in Linux 4.5, but it breaks the sandbox.
++#undef MADV_FREE
++#endif
++
+ #ifndef MADV_FREE
+ #define MADV_FREE MADV_DONTNEED
+ #endif