aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-10-14 13:24:25 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-10-14 13:30:20 +0200
commit94dae47b787b95188708420ea5c8056ec7da73f7 (patch)
treeacce28383478feca3973e46171f228c0253c9d98 /community
parentb4dc3c61e51c2141d6e1b8e8b4831f827b136db2 (diff)
downloadaports-94dae47b787b95188708420ea5c8056ec7da73f7.tar.bz2
aports-94dae47b787b95188708420ea5c8056ec7da73f7.tar.xz
community/snapcast: respect our optimization level
Diffstat (limited to 'community')
-rw-r--r--community/snapcast/APKBUILD5
-rw-r--r--community/snapcast/respect-optimization-level.patch29
2 files changed, 33 insertions, 1 deletions
diff --git a/community/snapcast/APKBUILD b/community/snapcast/APKBUILD
index 2c4715d91d..6c26d74bac 100644
--- a/community/snapcast/APKBUILD
+++ b/community/snapcast/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=snapcast
pkgver=0.15.0
-pkgrel=0
+pkgrel=1
pkgdesc="Synchronous multi-room audio player"
url="https://github.com/badaix/snapcast"
arch="all"
@@ -14,6 +14,8 @@ pkggroups="$pkgname audio"
install="$pkgname-client.pre-install $pkgname-server.pre-install"
subpackages="$pkgname-doc $pkgname-client $pkgname-server"
source="$pkgname-$pkgver.tar.gz::https://github.com/badaix/$pkgname/archive/v$pkgver.tar.gz
+ respect-optimization-level.patch
+
$pkgname-client.initd
$pkgname-client.confd
$pkgname-server.initd
@@ -66,6 +68,7 @@ server() {
}
sha512sums="3751eeaa9be4ffd5c7633b8770f36e87360ab83004f090a8350e377f60a79d9502b92b92c5c9c35f513705e6484d113de9942f0a896824d7c5f806ba0010e84e snapcast-0.15.0.tar.gz
+85792a3edf8de76228d8114992f6fdfba6321aeca29d1f773038e88b96e1d6cdf9b6e3993eb09da934c8f561977827cb57f4b435c99405e5a2b4645edd2b5bd2 respect-optimization-level.patch
833ce6a5fecb023f32df340df98b5cfbecc765735d7133228dd703a6a0c7f2b67ac95aa787ac7119a2eb87e768e5c4deb12738d0b0354db3510d9047f9e9b24f snapcast-client.initd
fa353d7974d3a8b3b22ff009b762c7c4ee318f9f83e22762a9ebf550484b9fc3cc4dffd389b6d756630dc035cb86d5c5643541957785f8bbf71fe4915691c337 snapcast-client.confd
6d6b6ea52ecb13c74f1cc6aa777ee2c1c00c9f67c3383fede6b1ad6af522bc24b5a0684939e78c5e2af6f2f35259c7c536f04b63244098f561d0590a93a7ab9f snapcast-server.initd
diff --git a/community/snapcast/respect-optimization-level.patch b/community/snapcast/respect-optimization-level.patch
new file mode 100644
index 0000000000..614d9eee4c
--- /dev/null
+++ b/community/snapcast/respect-optimization-level.patch
@@ -0,0 +1,29 @@
+The value of the DEBUG variable is append to CXXFLAGS, thereby
+overwriting the optimization level set in the CXXFLAGS environment
+variable (-Os on alpine by default). Since we prefer to use our
+optimization level DEBUG needs to be unset.
+
+diff -upr snapcast-0.15.0.orig/client/Makefile snapcast-0.15.0/client/Makefile
+--- snapcast-0.15.0.orig/client/Makefile 2018-10-14 13:27:11.247287578 +0200
++++ snapcast-0.15.0/client/Makefile 2018-10-14 13:27:26.187330181 +0200
+@@ -31,7 +31,7 @@ else
+ endif
+
+ # Simplify building debuggable executables 'make DEBUG=-g STRIP=echo'
+-DEBUG=-O3
++DEBUG=
+
+
+ CXXFLAGS += $(ADD_CFLAGS) -std=c++0x -Wall -Wno-unused-function $(DEBUG) -DHAS_FLAC -DHAS_OGG -DASIO_STANDALONE -DVERSION=\"$(VERSION)\" -I. -I.. -isystem ../externals/asio/asio/include -I../externals/popl/include -I../externals/aixlog/include -I../externals -I../common
+diff -upr snapcast-0.15.0.orig/server/Makefile snapcast-0.15.0/server/Makefile
+--- snapcast-0.15.0.orig/server/Makefile 2018-10-14 13:27:11.257287607 +0200
++++ snapcast-0.15.0/server/Makefile 2018-10-14 13:27:18.830642536 +0200
+@@ -31,7 +31,7 @@ else
+ endif
+
+ # Simplify building debuggable executables 'make DEBUG=-g STRIP=echo'
+-DEBUG=-O3
++DEBUG=
+
+
+ CXXFLAGS += $(ADD_CFLAGS) -std=c++0x -Wall -Wno-unused-function $(DEBUG) -DHAS_FLAC -DHAS_OGG -DHAS_VORBIS -DHAS_VORBIS_ENC -DASIO_STANDALONE -DVERSION=\"$(VERSION)\" -I. -I.. -isystem ../externals/asio/asio/include -I../externals/popl/include -I../externals/aixlog/include -I../externals -I../common