aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-10-14 13:18:38 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-10-14 13:18:38 +0200
commitb4dc3c61e51c2141d6e1b8e8b4831f827b136db2 (patch)
treeb003a2c6552941beeb95eb3faec83ad5208ee0a7 /community
parent8d213358254fd1dc606bbd7f92f1ea299b6d5c56 (diff)
downloadaports-b4dc3c61e51c2141d6e1b8e8b4831f827b136db2.tar.bz2
aports-b4dc3c61e51c2141d6e1b8e8b4831f827b136db2.tar.xz
community/snapcast: declare functions in the order they are executed
PR https://github.com/alpinelinux/aports/pull/4541 removed the check() function entirely. However, we didn't establish a clear policy yet regarding what to do when upstream doesn't proved a test suite. Therefore I will just leave check() as is even though I consider this to be somewhat useless.
Diffstat (limited to 'community')
-rw-r--r--community/snapcast/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/community/snapcast/APKBUILD b/community/snapcast/APKBUILD
index 05fc2e99ab..2c4715d91d 100644
--- a/community/snapcast/APKBUILD
+++ b/community/snapcast/APKBUILD
@@ -26,6 +26,12 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ client/snapclient --help > /dev/null
+ server/snapserver --help > /dev/null
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" installclient installserver
@@ -59,12 +65,6 @@ server() {
"$subpkgdir"/etc/conf.d/"$subpkgname"
}
-check() {
- cd "$builddir"
- client/snapclient --help > /dev/null
- server/snapserver --help > /dev/null
-}
-
sha512sums="3751eeaa9be4ffd5c7633b8770f36e87360ab83004f090a8350e377f60a79d9502b92b92c5c9c35f513705e6484d113de9942f0a896824d7c5f806ba0010e84e snapcast-0.15.0.tar.gz
833ce6a5fecb023f32df340df98b5cfbecc765735d7133228dd703a6a0c7f2b67ac95aa787ac7119a2eb87e768e5c4deb12738d0b0354db3510d9047f9e9b24f snapcast-client.initd
fa353d7974d3a8b3b22ff009b762c7c4ee318f9f83e22762a9ebf550484b9fc3cc4dffd389b6d756630dc035cb86d5c5643541957785f8bbf71fe4915691c337 snapcast-client.confd