aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-03-07 20:19:00 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-03-07 20:19:00 +0000
commitbdfa202aa53b0a485d8be18beb147a16c9b726b3 (patch)
tree09be0c0175e22cd21d9f02e9cda965fbba498646 /community
parente219052b96a285a22aa007f0b41a169931855fa1 (diff)
downloadaports-bdfa202aa53b0a485d8be18beb147a16c9b726b3.tar.bz2
aports-bdfa202aa53b0a485d8be18beb147a16c9b726b3.tar.xz
community/texmf-dist: defang up2date
Diffstat (limited to 'community')
-rw-r--r--community/texmf-dist/APKBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/community/texmf-dist/APKBUILD b/community/texmf-dist/APKBUILD
index c7fa9c5e51..ae64527fdf 100644
--- a/community/texmf-dist/APKBUILD
+++ b/community/texmf-dist/APKBUILD
@@ -23,8 +23,7 @@ pkgver=${_core}
pkgrel=1
pkgdesc="TeX Live texmf core distribution"
url="http://tug.org/texlive/"
-# Temporarily disabled, builders are trying to rebuild it over and over again.
-#arch="noarch"
+arch="noarch"
license="GPL"
depends=""
depends_dev=""
@@ -75,6 +74,19 @@ source="
"
options="!check"
+# as this is a meta APKBUILD, we need to defang up2date as versions may not directly match
+# the APKBUILD version
+up2date() {
+ getpkgver || return 1
+
+ if [ ! -f "$REPODEST/$repo/$CARCH/$pkgname-$pkgver-r$pkgrel.apk" ]; then
+ msg "$REPODEST/$repo/$CARCH/$pkgname-$pkgver-r$pkgrel.apk"
+ return 1
+ fi
+
+ return 0
+}
+
unpack() {
# Prevent unpacking by overwriting the unpack() function
return 0