aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-06-09 12:45:59 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-06-09 12:47:41 +0000
commitec8a794b401db355941896134ed67efe8d02aca4 (patch)
treeee395e48f722459af4a0e836c9381da5a86b097b /community
parentb772d02ae88c739ecaaead7e583807b2e968a236 (diff)
downloadaports-ec8a794b401db355941896134ed67efe8d02aca4.tar.bz2
aports-ec8a794b401db355941896134ed67efe8d02aca4.tar.xz
community/py-urllib3: moved from testing
Diffstat (limited to 'community')
-rw-r--r--community/py-urllib3/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/community/py-urllib3/APKBUILD b/community/py-urllib3/APKBUILD
new file mode 100644
index 0000000000..99aaa36706
--- /dev/null
+++ b/community/py-urllib3/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Yura Kushnir <kushnir.yura@gmail.com>
+# Maintainer: Yura Kushnir <kushnir.yura@gmail.com>
+pkgname=py-urllib3
+_pkgname=${pkgname/py-/}
+pkgver=1.21.1
+pkgrel=0
+pkgdesc="HTTP library with thread-safe connection pooling, file post, and more."
+url="https://github.com/shazow/urllib3"
+arch="noarch"
+license="MIT"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.zip::https://github.com/shazow/urllib3/archive/$pkgver.zip"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="01750e8f970d7cb31c155f2294172fdab8cbd311787b44a1d6dedb40b1b5e21d5c694f5f2ca3e24c68751f596f4ad6f3b9876d2614c46dde72b66c081b96a220 py-urllib3-1.21.1.zip"