aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-05-22 11:35:59 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-05-22 11:37:10 +0000
commit052fcc57045f4e5ead47f1136b6385ea85123c03 (patch)
treeb249b28f490889b0fdab5b2356f68358428fb1e7 /community
parente6421602f600831f362bf96ddc36ecefbefec3d1 (diff)
downloadaports-052fcc57045f4e5ead47f1136b6385ea85123c03.tar.bz2
aports-052fcc57045f4e5ead47f1136b6385ea85123c03.tar.xz
community/mkvtoolnix: moved from testing.
This fixes, partially, #7294. The unit test requires an external pacakge that is not yet available on alpine (googletest).
Diffstat (limited to 'community')
-rw-r--r--community/mkvtoolnix/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/mkvtoolnix/APKBUILD b/community/mkvtoolnix/APKBUILD
new file mode 100644
index 0000000000..393bd86952
--- /dev/null
+++ b/community/mkvtoolnix/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=mkvtoolnix
+pkgver=12.0.0
+pkgrel=0
+pkgdesc="Set of tools to create, edit and inspect Matroska files"
+url="https://mkvtoolnix.download/index.html"
+arch="all"
+license="GPL"
+makedepends="libmatroska-dev flac-dev libvorbis-dev boost-dev
+ zlib-dev file-dev libogg-dev ruby-rake ruby-json bash docbook-xsl"
+options="!check"
+subpackages="$pkgname-doc"
+source="https://mkvtoolnix.download/sources/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure CC="${CC:-gcc}" CFLAGS="${CFLAGS}" \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --without-gettext
+ rake V=1 -j${JOBS}
+}
+
+package() {
+ cd "$builddir"
+ rake DESTDIR="$pkgdir" install
+}
+
+sha512sums="ccb9c0e368f7fb9cfb2bebaa9f4ef248ccb1aca78136b4e653d32a4319316281d4dd63cfd935c6aa18f1294a17493f61462d13f0552d257b058245019cfe6935 mkvtoolnix-12.0.0.tar.xz"