aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-08 10:43:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-08 10:43:10 +0000
commit0b485b75b64cbd27b349ab286c182190742e9e12 (patch)
treec6a5282bf35ce4dd2b779fa921b9b5b5c3ac4a5e /community
parent5777b04e8e41bbd6d24b0d3ec65f2aaa096ced34 (diff)
downloadaports-0b485b75b64cbd27b349ab286c182190742e9e12.tar.bz2
aports-0b485b75b64cbd27b349ab286c182190742e9e12.tar.xz
community/lua-http: backport fix for lpeg_patterns-0.5
lpeg_patterns 0.5 broke lua-http. backport upstream fix. https://github.com/daurnimator/lua-http/issues/132
Diffstat (limited to 'community')
-rw-r--r--community/lua-http/APKBUILD11
-rw-r--r--community/lua-http/lpeg_patterns-0.5.patch37
2 files changed, 44 insertions, 4 deletions
diff --git a/community/lua-http/APKBUILD b/community/lua-http/APKBUILD
index 787ddc59bd..cc88dbcae7 100644
--- a/community/lua-http/APKBUILD
+++ b/community/lua-http/APKBUILD
@@ -2,16 +2,18 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=lua-http
pkgver=0.2
-pkgrel=1
+pkgrel=2
pkgdesc="HTTP Library for Lua that supports HTTP(S) 1.0, 1.1 and 2.0"
url="https://github.com/daurnimator/lua-http"
arch="noarch"
license="MIT"
-depends="lua-cqueues lua-basexx lua-fifo lua-lpeg lua-lpeg_patterns lua-ossl"
+depends="lua-cqueues lua-basexx lua-fifo lua-lpeg lua-lpeg_patterns>=0.5 lua-ossl"
checkdepends="lua-busted lua5.1-compat53 lua5.2-compat53 lua5.1-bit32"
makedepends=""
subpackages=""
-source="$pkgname-$pkgver.tar.gz::https://github.com/daurnimator/$pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/daurnimator/$pkgname/archive/v$pkgver.tar.gz
+ lpeg_patterns-0.5.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
case "$CARCH" in
@@ -64,4 +66,5 @@ _subpackage() {
echo 'rock_manifest = {}' > "$rockdir"/rock_manifest
}
-sha512sums="ed71ac09277e8602e3d4954541f06c09ef444db20e5b4e39a17b9ed4893046b1442969902c0ba84fc4c3c922a6d1c8ebf853fceda261b12bf10ea9aa24389587 lua-http-0.2.tar.gz"
+sha512sums="ed71ac09277e8602e3d4954541f06c09ef444db20e5b4e39a17b9ed4893046b1442969902c0ba84fc4c3c922a6d1c8ebf853fceda261b12bf10ea9aa24389587 lua-http-0.2.tar.gz
+9ce9038c69bb6d4730cf7717fde9c47447eafbe050dd88a6e60930a9cca63f80598f379885627b06f45e744fe6d59531c58d25565834a1963c81b884560710cc lpeg_patterns-0.5.patch"
diff --git a/community/lua-http/lpeg_patterns-0.5.patch b/community/lua-http/lpeg_patterns-0.5.patch
new file mode 100644
index 0000000000..7034c07551
--- /dev/null
+++ b/community/lua-http/lpeg_patterns-0.5.patch
@@ -0,0 +1,37 @@
+From d5d948bbecf5b88ebb099d95a6fae111ffe13bab Mon Sep 17 00:00:00 2001
+From: daurnimator <quae@daurnimator.com>
+Date: Sun, 15 Jul 2018 23:12:25 +1000
+Subject: [PATCH] http/request.lua: Use new lpeg_patterns 0.5 capture format
+
+---
+ README.md | 2 +-
+ http-scm-0.rockspec | 2 +-
+ http/request.lua | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/README.md b/README.md
+index a7183c3..91e2c6c 100644
+--- a/README.md
++++ b/README.md
+@@ -33,7 +33,7 @@ This will automatically install run-time lua dependencies for you.
+ - [luaossl](http://25thandclement.com/~william/projects/luaossl.html) >= 20161208
+ - [basexx](https://github.com/aiq/basexx/) >= 0.2.0
+ - [lpeg](http://www.inf.puc-rio.br/~roberto/lpeg/lpeg.html)
+- - [lpeg_patterns](https://github.com/daurnimator/lpeg_patterns) >= 0.3
++ - [lpeg_patterns](https://github.com/daurnimator/lpeg_patterns) >= 0.5
+ - [fifo](https://github.com/daurnimator/fifo.lua)
+
+ To use gzip compression you need **one** of:
+diff --git a/http/request.lua b/http/request.lua
+index aa80648..fccd843 100644
+--- a/http/request.lua
++++ b/http/request.lua
+@@ -36,7 +36,7 @@ local request_mt = {
+ }
+
+ local EOF = lpeg.P(-1)
+-local sts_patt = lpeg.Cf(lpeg.Ct(true) * http_patts.Strict_Transport_Security, rawset) * EOF
++local sts_patt = http_patts.Strict_Transport_Security * EOF
+ local uri_patt = uri_patts.uri * EOF
+ local uri_ref = uri_patts.uri_reference * EOF
+